Shop Learn
new prop stops at 86% — Parallax Forums

new prop stops at 86%

I bought a new prop chip because, i believe, i burned the one i had.
the problem is that im trying to make it say a hello via the Simple IDE and it it at 86% and wont do anything else.
Do i have to do anything to make it work? isnt it suppose to be plug and play?


  • What does your hardware circuit look like? Are you using the Prop in a breadboard? Do you have decoupling caps on the power lines? How are you powering the Prop?
  • Must be a glinch in the simpleIDE. Because it doesnt happen in another pc. Yet i find the new version RC2 to be slower when uploading even a simple print.
  • Are you downloading to RAM or EEPROM. If the EEPROM is not present, that may be a problem.
  • eerom is optional. no its just run with terminal...
  • Now it doesnt work in none. Great!
  • Dave Hein wrote: »
    What does your hardware circuit look like? Are you using the Prop in a breadboard? Do you have decoupling caps on the power lines? How are you powering the Prop?

  • johnproko, there's no way we can help you if you don't give us more information. Please answer the questions I asked you in my previous post.
  • Prop 40 dip on a breadboard ( I have one with eeprom and crystal and one without.
    I am using a 4x AA battery, might be about 5v and about 4Amps. I am starting to believe that it is a software problem and not the chips because the power led connected to them is on. If anyone had the same problem. I have restored the laptop to a previous state, didnt work, trying to uninstall and re-install the simpleIDE, doesnt work (downloads yet it cannot load). Might need to inform parallax, yet I am still cautious as I have recently toasted a prop chip so...
  • BTW I am using W10.
  • So are you using both the 5V and 3.3V regulators, or just the 3.3V one?
  • I am using both, doesnt affect anything.
    It is the simpleIDE problem because everything else works (prop tool, bs2, arduino).
    Does anyone have a previous version of it to upload?
  • Breadboards do age and wear out. It is possible that connections become intermittent or high resistance.

    Using an LED to indicate proper voltage is deceptive. It is much better to get a little switcher that displays Volt. It can toggle from input side to output side, so you can monitor that actual voltage while programing.

    If you don't want to buy that, just use a multimeter to monitor the voltage at the Propeller pins - not anywhere else.
  • John, with the information from two posts back now in play, i'd change the subject of post to something like "problem loading Prop sith SimpleIDE RC2" so the proper people take notice. Many of us don't use SimpleIDE so we've gone after the more common general loading problems. Telling us it loads fine under Prop Tool and but changes the problem area.
  • The voltage is fine, I have used multimeter and know from experience that a burned chip wont light the led.
  • LoopyBytelooseLoopyByteloose Posts: 12,537
    edited 2015-12-05 17:33
    Sorry, I was thinking it might be an insertion problems in the breadboard - not a 'burned chip'.

    If you can load the original Propeller IDE (aka Propeller Tool) to the same computer and it works, that would confirm the Simple IDE problem.

    But I will shut up as it seems that Simple IDE might have a problem with W10 that I know nothing about.
  • johnproko wrote: »
    I am using both, doesnt affect anything.
    It is the simpleIDE problem because everything else works (prop tool, bs2, arduino).
    I don't see how the bs2 and arduino are relevant to a Prop problem. You say that the prop tool works. So you are saying that you can load and run programs on the chip using the Prop tool, correct? Does the "burned chip" also still work with the Prop tool?

    If you are using both the 5V and 3.3V regulators you could have a problem with 4 AA batteries if they are slightly drained, or if you are pulling a lot of current. The minimum input voltage for the 5V regulator is 6 volts, so if the AA batteries are drained they could be below the minimum voltage. I've had problems using 9V batteries that were almost dead, where programs that used just one cog worked OK, but programs using multiple cogs would fail due to the higher current drain and resulting voltage drop.

  • johnprokojohnproko Posts: 121
    edited 2015-12-06 10:50
    The battery is not the problem. I have managed to "activate" both props and light a led using the proptool, yet it cannot print in the terminal.
    It is really nerve breaking :-(
  • I am sure Parallax would just swap out the Propeller in question, if that is really what you desire.

    The other issues is if there is an unresolved bug in Simple IDE when installed in Windows 10 on some computers (yes it may be one computer's BIOS or something). I think now that the idea has been expressed, Parallax would like to make sure they can help anyone else with similar Simple IDE problems on Windows 10.

    So I guess I have clarified -- Can you get what you want? and can Parallax get what it wants? Most importantly, Parallax wants you to be a satisfied customer. They might skip what they want.
  • Dave HeinDave Hein Posts: 6,278
    edited 2015-12-06 13:40
    johnproko wrote: »
    The battery is not the problem. I have managed to "activate" both props and light a led using the proptool, yet it cannot print in the terminal.
    It is really nerve breaking :-(
    So this is what we know:

    - Both Props load from the Prop Tool
    - Both Props do not print to the terminal
    - Neither Prop works with SimpleIDE. The loading stops at 85% on both.

    Are those statements correct?

    Now let's figure out why your program doesn't print to the terminal. What terminal program are you using? Are you using the Propeller-Serial-Terminal program? Could you post your code? Maybe there's a problem with the code. Do you have a WAITCNT at the beginning of your program to give you time to start the Prop terminal?

    If you answer all my questions we can probably resolve your problem in a short period of time. If you don't answer the question it could be days before we finally realize what the problem is.
  • I'm guessing that inadequate bypassing is the problem. That would explain not working with the terminal if the usual PLL failure mode, typically resulting from poor bypassing, is the culprit.


    What kind of bypass caps did you use, how many are there, and where are they located on your breadboard?

  • PublisonPublison Posts: 11,861
    edited 2015-12-06 19:24
    Also, If you are trying to start the terminal without a crystal it may not work. The baudrate is tied to having a steady clock signal.

    Many of the questions go unanswered. What is needed is the code and a picture of the setup.

  • Hi all, sorry for not posting.

    Indeed Publison the crystal makes the difference, as I try to mix the equipment I have on the board.
    Using the crystal will make the led high/low, although using the proptool it was fine even if i didnt use it.
    Remember that the crystal is optional, as well as the eeprom.
    So far I have been able to light a led, NEVERTHELESS printing in the terminal is not functioning.
    Now before I blame W10, I used W8.1 and even tried to print using the proptool with no success.
    The problem is something else.
    FYI I did manage to print in the terminal for just once when the new chip came, yet it was a simple test to see if
    everything was ok. Since then nothing. It is so frustrating!

    This leaves us:
    -Both props light a pin in simpleIDE
    -Both props dont print in terminal using simpleIDE and Proptool.
  • So are you using a crystal or not? Serial will not work reliably without a crystal.
  • johnproko wrote: »
    Remember that the crystal is optional, as well as the eeprom.

    As David said, the xstal is not optional when using the serial terminal.

  • PublisonPublison Posts: 11,861
    edited 2015-12-06 23:17
    Sorry, without pictures of the setup and code you are using, you are not going to get definitive answers.
  • In this diagram it says optional for both.
    I will try to upload a photo later because I am from a phone.
  • Unfortunately, Page 5, 2.3.1, does not show the capacitors need between Pins 39 and 22; and 9 and 12. Without these capacitors, the PLL might fail.
  • Without a crystal, the Propeller uses an internal oscillator, and the spec for that oscillator isn't very good - There's a decent chance it will drift outside of the acceptable range for serial communication. This is more likely at higher speeds - what baud rate are you attempting to connect at? You could try lowering it down to something like 4800 to see if that helps.

    In addition to that, not having a decoupling / bypass capacitor between power and ground near the Propeller itself will cause issues as well. Anything that causes minor power surges, like lighting an LED or toggling the serial pin, will cause the power to fluctuate and introduce noise. Putting a 1uF cap (or a 0.1uF if that's all you have) between the pins will help filter noise. Using both is even better, because they handle different noise frequencies.
  • The datasheet is really remiss in not including the needed bypass caps. There should also be one on the EEPROM. A 10 uF filter cap where the power comes in is also advisable.

  • LoopyBytelooseLoopyByteloose Posts: 12,537
    edited 2015-12-08 15:38
    It also might be a lack of the proper capacitor sizes on the regulators. We know that 7805 device takes different value capacitors than the low drop out regulators - like the LM2937-5. Parallax can't explect a new user to sort out all the details of voltage regulators without telling them they require different support components.

    But pondering this points to a more general issue with selling DIP microcontrollers to those that want to DIY learning in electronics by breadboarding.

    We seem to have a 'Just go for it' culture, that skips a lot of helpful assistance at the entry point. With the BS2, everything was prewired, and even with the Parallax Forum always had someone new to them struggling with getting the serial interface for program. That issue still carries over to the Propeller. And it likely will never go away.

    But here we have the added challenges of proper breadboarding and proper power configuration. I suppose that we need to document a 'Tried and True' starter solution for breadboard.

    The fact that a crystal MUST be used for SERIAL INPUT AND OUTPUT after programing the Propeller or the EEPROM, but programming doesn't required a crystal hasn't been made clear in starter solutions. And I am still wondering if it MUST be a 5Mhz crystal and no other.

    I have never bothered to dig for clear answers as the 'accepted' usual way of doing things just worked for me.

    And of course, a start solution should also include the fact that all the Grounds and all the V+ have to be included in wiring to avoid trouble.

    The OP here obviously has acquired some rather exotic ideas of what passes for good practise in breadboarding and resolving wiring failures. One can't just read schematics or the main datasheet PDF. Those often presume that the reader has developed the knowledge and skills to avoid problems in a breadboard situation. Application Notes for knowledgible users are not appropriate either.

    I feel that a special kind of Application Note seems needed, something like a HOWTO document.

    Without the right document placed on Parallax's Downloads in appropriate places, Forum members will keep having to take up the slack of presenting the right way to get started without frustration. And it is rather hit or miss that the Forum members will do the job right.

    Also, a box at the top of the datasheet mentioning that there is a good HOWTO construct a success first breadboard for users new to electronics and microcontrollers, might provied other a less frustrating first experience.

    Obviously, a good first experience really builds a lot of confidence in Parallax and its products. A bad one looses business.
Sign In or Register to comment.