***~~~ Parallax Servo Controller Problem ~~~***

eflyefly Posts: 34
edited 2005-02-09 - 13:59:19 in Robotics
I· need to build a robot that need to control 6 servo at same time. Now I have a Basic Stamp Module (Rev A) and a Parallax Servo Controller (Rev B). But sometime I run the PSC, the servo is keep vibrate and not function. For the PSC I am using the power source of 5VDC;500mA, because I am using· a AC adapter covert the 5 Volt power to DC, what I know is a standard servo only require 8mA current, is this the problem that make servo not function?
·
·Appreciate f someone can help me solve this problem.

Comments

  • steve_bsteve_b Posts: 1,563
    edited 2005-02-09 - 13:31:50
    If you disconnect the 5 other servo's, does it still shake?· If not, then YES, it's probably a power supply issue.· If it still shakes, then swap it out with other servo's....do those servo's shake too....then you have a code problem.
    I've not used the servo controller, so am not too sure how you code to it....but you have to allow a delay somewhere around 20ms in between pulse commands or the servo's will shudder.· This is an issue when going straight from a stamp....so I'm not sure what happens when you use the Servo Controller (and I'm currently too lazy to go read the spec--it's too early!).

    So, try running one servo and then swapping other servo's in to that position to see if it still shudders.
    I couldn't tell if you meant all servo's shuddered or if just one did....so that's why I replied wrt one servo being an issue.

    ▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
    ·

    Steve
    http://members.rogers.com/steve.brady
    "Inside each and every one of us is our one, true authentic swing. Something we was born with. Something that's ours and ours alone. Something that can't be learned... something that's got to be remembered."
  • eflyefly Posts: 34
    edited 2005-02-09 - 13:48:17
    Yes, thanks steve, I try 4 servo is in good condition, but if more than that, let said all six servo will cause shaking and no function. (So I don’t think this is the stamp code problem)

    Addition, I just read the previous message that might cause the problem I face:

    http://forums.parallax.com/forums/default.aspx?f=10&m=56655

    So, if I use PSC control total 16 servo (Each ~ servo required 4.8V, 8mA), what is the power supply I need to use? (especially current, is that any formula can calculate the current required that I can bought one)

    Is any one have good idea?
  • steve_bsteve_b Posts: 1,563
    edited 2005-02-09 - 13:59:19
    efly:

    it's a sure bet that if, by connecting more servo's, they start shaking, then you're power supply isn't sufficient enough.

    From that post, they said it could suck up to 500mA per servo.· sounds like a lot....but that could well be.
    So, for 6 servo's....at a max pull, you'd need 3Amps.

    Firstly, I'd make sure my stamp and controller are both on separate supplies from the servo's.· Servo's can suck so much power that they'll cause the stamp to 'brownout' and reset (not sure what the controller would experience).

    As far as, 'What could you use?'....by a wal-wart with a larger rating....and use a regulator of an appropriate rating as well.
    If you have some supplies on hand but don't have a large enough regulator for all 6 servo's....then use a couple regulators with a proper number of servo's on each.· Just a thought.

    ▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
    ·

    Steve
    http://members.rogers.com/steve.brady
    "Inside each and every one of us is our one, true authentic swing. Something we was born with. Something that's ours and ours alone. Something that can't be learned... something that's got to be remembered."
Sign In or Register to comment.