Shop Learn
PropTool 2.4 — Parallax Forums

PropTool 2.4

bambino69bambino69 Posts: 90
edited 2020-11-23 19:04 in Propeller 2

After upgrading to this version the formatting was off. The same is true if I use the 2.3 alpha mod as well.
Has any else seen this and if not how do I correct it?
1284 x 802 - 47K
SS.png 46.9K

Comments

  • AwesomeCronkAwesomeCronk Posts: 1,029
    edited 2020-11-23 22:47
    That looks like your source file may have been corrupted and the Prop Tool is printing some weird characters. Try loading the file up in notepad and see if it’s ok there. You may want to make sure notepad is using the parallax font. (Parallax.ttf file somewhere in the Prop Tool install directory.)

    Edit: On closer inspection, it actually looks like the Prop Tool is rendering the text with weird spacing. I have no idea how to fix that...
  • That looks more like the Parallax.ttf isn't installed at all.
  • It is the spacing it seems. It looks like that as I type, not file problem.
    If I enable line numbers only the left most digit is readable.
  • Just checked Windows\fonts and did not see parallax.ttf
    I reinstalled proptool still no font!
  • I have uninstalled and went back to ver1.3.2 and using it with the 2.3 alpha mod.
    It still works properly.
    Nobody else had this problem?
    The gremlin king strikes again!
  • I can confirm that version 2.4r2 does NOT install the Parallax True Type Font, however, if you install version 1.3.2 which does install the Parallax(.ttf), Version 2.4r2 will work correctly.
  • Just a note. Version 1.3.2 is not on the new site but can be downloaded from the old site.
  • cgraceycgracey Posts: 13,563
    edited 2020-11-24 09:23
    We will get this straightened out tomorrow. Sooty for the headaches .
  • PropGuy2PropGuy2 Posts: 327
    edited 2020-12-01 00:18
    I tried to download the new Prop Tool 2.4 for Windows several times from the new website, and on different computers ( 2 using Win 7 and one laptop using Win 10 ) - all the downloads "failed" No other explanations, didn't find a virus, it just failed the download. Any help is appreciated.

    UPDATE - All servers are not created equal, slow transfer rates could be a problem and they somehow just time out. - Another served downloaded the Prop Tool 2.4 just fine.
  • PropGuy2
    Chip says he will have it fixed soon. Till then, downloading the 2.4 will be a headache to read anyway.
    The latest version probably won't be 2.4 either by then. We just need to sit tight till parallax post's the fix.
  • I downloaded and ran PropTool 2.4 today and didn't have any font problems. Make sure you have the Parallax.ttf font installed, and try another size -- the font is nice but doesn't scale perfectly.
  • CJMJCJMJ Posts: 194
    edited 2020-11-24 21:39
    I filed a bug report on 2.4r2 this morning. The developer has fixed the issue and released 2.4r3. I haven't tested the new release yet. This may have been the reason for the failed downloads earlier. If you have version 1.3.2 installed and installed 2.4r2 you would not have experienced this problem. BTW: The True Type Font was in the /Program Files(x86)/Parallax Inc/Propeller Tool directory. It just wasn't installed.
  • CJMJCJMJ Posts: 194
    edited 2020-11-24 22:38
    Version 2.4r3 didn't install the font either. I dragged it from /Program Files(x86)/Parallax Inc/Propeller Tool into the Windows/Font directory and it installed and the problem in Version 2.4r3 has been corrected. I'm amending the bug report. The developer did state it was tested on a 'Virgin Windows 10 VM'. Also, I'm not sure about anyone else, but I'm installing my software on a (D) drive instead of the C: drive. I put 'D colon' the first time and the forum editor replaced it with a meme. Funny.
  • Downloaded,installed, and smiling😊
  • Another bug, F10 works fine for spin2 files, but Ctrl F10 attempts to locate a propeller 1 device to load!
  • Just a few last words. After additional testing it appears the 1.3.2 installer (or rather uninstaller) does NOT [correctly] remove/uninstall the Parallax.ttf file it installed [even though the /windows/Fonts explorer window does not show it installed].


    You have to manually remove it via command line [or reinstall the Parallax.ttf font]. This is the log entry from the installation of 2.4r3 (as suggested by the developer):

    2020-11-24 21:05:57.692 Dest filename: D:\Program Files (x86)\Parallax Inc\Propeller Tool\Parallax.ttf
    2020-11-24 21:05:57.705 Time stamp of our file: 2020-11-24 08:28:06.000
    2020-11-24 21:05:57.705 Installing the file.
    2020-11-24 21:05:57.910 Successfully installed the file.
    2020-11-24 21:05:57.911 -- File entry --
    2020-11-24 21:05:57.912 Dest filename: C:\WINDOWS\Fonts\Parallax.ttf
    2020-11-24 21:05:57.912 Time stamp of our file: 2020-11-24 08:28:06.000
    2020-11-24 21:05:57.912 Dest file exists.
    2020-11-24 21:05:57.912 Skipping due to "onlyifdoesntexist" flag.

    This is an 'ls Para*' from the directory:

    -a---- 1/25/2006 8:34 AM 1444060 Parallax.ttf

    Once the 1.3.2 parallax.ttf file has been manually removed, everything works as expected.

    Hope this helps.
  • Where do you download Prop tool 2.4?
  • It's in a really goofy location under 'Support' | 'Downloads' | 'Propeller 1 Software'

    https://www.parallax.com/package/propeller-tool-software-for-windows-spin-assembly-2/

  • Just noticed that object info("F8") Shows stack free no matter what code I'm running
  • CJMJCJMJ Posts: 194
    edited 2020-11-28 23:54
    It seems only spin2 files have this problem (i.e. no object info at all) whereas "Object Info" works fine with spin files. I didn't see any open/or closed issues on this so I'll go ahead and open one.
  • Thanks
Sign In or Register to comment.