P1 DIY minimal dev board - a weekend project (completed).



  • I don't agree that you need to connect "all the capacitors", it has more to do with ground itself. You should never have a heavy or inductive load depend upon a high current path that effectively flows through the Prop ground pins. The Prop grounds should nonetheless essentially be a short-circuit, not a "long circuit".
  • My minimal P1 dev board is completed. Finally .

    What is known at this point is it exists and I built it with my own hands using whatever parts I could find in my parts’ bin and ended up buying only the ones I didn’t have: a P1 chip and a suitable EEPROM.

    It features:
    - a P1 chip with all of its IOs broken out to the boards’ pins,
    - a 64KB I2C EEPROM,
    - a 5 MHz crystal, hard wired but it won’t be that much difficult to replace, if it ever comes to that,
    - two buttons - one meant to serve as a reset button and the other one as a user button (not hard wired to any particular pin nor decoupled with the capacitors so pretty much universal),
    - two LEDs for visual output - one orange and one red (both fairly low power, in series with 1 kOhm resistors, not hard wired to any particular pin so these are universal as well),
    - a simple NPN transistor reset circuit intended for use with the cheap usb-to-serial adapter board for programming purposes as I do not have a Plug nor I intend to buy one,
    - a 3.3V linear voltage regulator to supply enough current to the board and possibly accompanying boards as well. This one is hard wired but can be bypassed when not needed.
    - a very, very tiny (8 solder points) prototyping area.

    It lacks at least these features:
    - P1 IOs’ protection - this is a major factor to be seriously considered when handling the board but leaving these IOs unprotected was intentional.
    - enclosure - this is not the board feature per se but it would come handy to have it somehow mechanically protected. Maybe later, if ever. I don’t have time for this at present.
    - looks - the board, as you can see, is ugly. I new that from the very start that it would not be pretty but that’s not important to me.

    What is not known is if it actually works. It hasn’t released the magic smoke yet but that’s no proof.

    I’m pondering the complete write up on this little project with all the pros and cons an the whole idea behind it (with a few pictures; no video - sorry) and posting it on this great forum but that only after I confirm the board to actually work and there is a need of such stuff.
    If any of the two is not the case I’ll move on (meaning I’ll fix the board and start learning on it and forget the whole project write up thing).

    Your thoughts on a write up ?

    Attached is a picture of my P1 minimal dev board (might use some proper cleaning but I don’t have anything to clean it with at the moment and the gel flux I used in the process is of a “no clean” type so ...).
    I think it deserves it's name "ugly".
    2129 x 1987 - 1M
  • Wow that is terrible. Someone's got a steady hand, I see.
  • I have a feeling that this won't be making it's way to the Parallax gallery :lol:
  • All it needs is some flushes and swabbing with isopropyl alcohol to get that flux off. Take the photo in good lighting without flash at a slight angle and it'll look pretty nice actually.
  • We don't see something like that very often.
  • Hi

    They say beauty is in the eye of the beholder- I see a thing of BEAUTY!
    Toys Tools don't have to be pretty pretty to provide many hours of fun.
    I personally think that hand soldering surface mount components takes care and skill, and is something I have shied away from (out of cowardice!) UNTIL NOW! You have motivated me to try this soon.
    I thank you.

  • Hi again

    Ok you've shown me yours- I'll show you mine!!
    Not pretty pretty but has given me hundreds of hours of fun.
    A 40 pin dip with a 3v3 and 0v strip (red and black) each side, and the pins come out on the blue strip.
    pins 16-23 have a vga adapter which is often used for debug and you can see other pins used for its testing out motor speed encoders driven by a stepper.
    I make up a little adapter for any peripherals/ sensors from some strips of sip pins bent to fit.
    I hope yours proves as useful as mine.

    1920 x 2560 - 2M
  • JRoarkJRoark Posts: 545
    edited 2020-08-23 - 18:10:05
    Maciek and Dave, I like it! Just a man with a plan, a soldering iron, a parts bin and a schematic! That’s a beautiful thing. (But yeah... a good wash with 99% isopropanol and a short bristle brush would make it shine!)

    Well done!
  • Cluso99Cluso99 Posts: 16,570
    edited 2020-08-23 - 20:36:56
    From what I know, the pll fails if all power and ground pins are not connected. Many have reported how robust the prop is despite some atrocities committed with everything still working. The IO pins are very robust so no issues with them being unconnected, at least for home use.

    I have never destroyed a prop, unless you count my 8 pin prop ;) My 24 pin DIP prop works just fine :)

    As others said, use isopropyl alcohol. First you can chip off hard flux with a tiny screwdriver. To make it neater, use tiny Kynar wire ~26awg (wirewrapping wire).

    Let us know when it’s working. The easiest is to connect to a pc via usb/serial and run PropTool and use the “identify” command. Next try downloading a program to flash a pin or output a serial message to the pc - you will need to run PST after downloading. Then program this into eeprom (PropTool will confirm the eeprom working) and repower the prop and confirm it works. I can post a simple serial program if you wish.

    TIP: For hand soldering, make the smt pads extend out at leas 0.5mm longer than smt recommended. Use plenty of flux, have copper braid handy to remove excess solder. I use a flux pen for hand soldering. 0603 Rs and Cs are fine but 0402 are a little harder. Practice makes perfect. While I have hand soldered all my pcbs first, I do have the luxury of a proper reflow oven for production.

    BTW Only document for your own records and our enjoyment, but you’ve likely got better things to do like programming your new pcb :sunglasses:
  • Sometimes I am forced to use proto board and I started with Perma-Proto. Very good quality.
    When I was searching for a source, Amazon came up with an alternative in black and less expensive. This can look reasonably professional but I tend to put interconnecting wires on the underside. I also have side-cutters that cut flush to the board which also results in a clean, smooth finish. Client was very impressed and so I didn't bother to mention "prototype" :lol:
  • Next will we see someone deadbug a P1 QFN?
  • Maciek wrote: »
    What is not known is if it actually works. It hasn’t released the magic smoke yet but that’s no proof.
    So, what's the verdict? Did it work when you powered it up and tried to load code?

  • Is this a PCB that you designed yourself or is this a generic QFP prototyping board?
  • MJBMJB Posts: 1,192
    now just load the Tachyon image with EXTEND loaded (more doesn't hurt)

    and you can use
    lsio to get an overview of the status of the IO pins (H,L,PullUp,PullLow,Float)

    and have fun

    1 HIGH
    1 LOW etc. to play your LEDs interactively
    10 FOR 1 HIGH 1 s 1 LOW 1 s NEXT

  • Thanks guys for all your support and comments.
    I am really enjoying participating in this great forum. The picture was meant as a proof my board exists. Just that. Nothing more. I built it to be a tool, not an art piece :). I put some effort in that activity, that is true. More than I initially anticipated but it deserved to be finished properly and so it is.
    Just to amuse you even more I am posting another picture. This time its the tools I used in this project. I used only these and nothing more.

    Now back to the most important question David Betz has asked. The answer is I don't know yet.
    It so happened my cheap usb>uart converter, based on a CH340G chip does not have a DTR line broken out to a connector. The stlink v2.1 usb>uarts on the nucleos I have do not have that line at all so all I need to do is to grab that big green thing and solder a wire to pin 13 of the CH340G chip and hope for it to work. But that is yet to happen. When it comes to the second of Davids' questions I used a generic type QFP adapter board of a 32-44-64 footprint variety exactly like the one on the other attached picture and worked from there.
    Even if it won't work at first, which I doubt but there is still that possibility, I'm determined to make it work anyway, no matter what it takes.
    BTW, the ugly board has seen some isopropyl alcohol treatment (I bought a small bottle of it today). It doesn't look any prettier but it is cleaner for sure.
    2063 x 2080 - 1M
    3212 x 2950 - 2M
  • Wow! You did all of that with a soldering gun? Amazing.
  • You can do without the DTR line: RTS works, too (you just need to configure whatever you're using to reset on RTS, it's not the default). Additionally, you can just manually hit reset at the right time and it'll work, too. Just needs a bit of practice to get the timing right (I recommend the "object info" window in Propeller Tool, for it has consistent delay between clicking "Load RAM" and it actually starting the load process)
  • Is that really an old school transformer type of soldering gun? OMG, really want to see if the thing works now. Those old guns were pretty hard on semiconductor parts.
  • @frank freedman Correct, sir. That's the thing.
    I got this as a present from my father when I was just a kid like 13 or 14 years old and that was many decades ago, and use it since then. It's seen a lot of use and abuse but still works fine. I used it with possibly every kind of semiconductors from early era russian germanium transistors, ttl and cmos chips and even sensitive to electrostatic mosfets. Perhaps I was lucky beyond belief but never damaged these parts because of the soldering gun. I was very hard to use on early, low quality, laminated boards tho. And that awful smell when the temperature got too high...
  • I had a big black one, not sure if it was weller or not, but had to remember to click it on to heat before getting near the semiconductor parts. Mostly used on big parts, iron for smaller. But for stench, few things beat the Radioshack P-box kits. These guns were a great cost saving two in one tool. Could solder heavy stuff and did not need to keep a degaussing coil as the gun was quite good for that as well.
  • ... but had to remember to click it on to heat before getting near the semiconductor parts.... These guns were a great cost saving two in one tool. Could solder heavy stuff and did not need to keep a degaussing coil as the gun was quite good for that as well.

    Exactly. You hit the nail on the head. Two times in a row :).

    "Ordnung ist das halbe Leben" - I didn't know that. Must make a note of it or just memorize it.
  • Back to business.
    I did a one wire mod to my usb>uart CH340G based dongle as I described above in one of the earlier posts, connected the power, Rx, Tx and the DTR line I already have made available, fired up the Propeller Tool (first I had to find and dust off my old win7 lenovo x200s laptop and install the tool, of course) then connected everything together and....well, nothing.
    Then I hit F7 and got this sweet little pop up saying the Prop tool recognized my P1 chip. So far so good. Then i downloaded Peters' jewel - the Tachyon binaries (all I could find at his site at sourceforge) and tried to load it to P1 RAM and it failed. Tried to load the binary to the EEPROM and it understandably failed as well. Then I took another binary and did the same. No luck. Next I re-checked the serial port settings and found everything was ok. Not so good this time.
    I don't give up easily so I gave myself a moment to think and figured that since the tool recognizes the chip properly the fault is not with the board I made. It must be something on the software side. Then I took a simple uart example that came with the Prop tool and it compiled and loaded correctly to RAM and to EEPROM.

    The conclusion - my ugly P1 dev board I so stubbornly built is very ugly indeed but IT WORKS !

    For those who'd like to see a proof (I'm one of that variety myself) there is a picture attached to this post.

    Now, I'd appreciate if somebody here could give me a friendly hint on how to properly load a Tachyon binary ?
    The ones I tried were initially preconfigured to use 10 or 6 MHz and my board uses 5MHz crystal and that might be a cause for failure to load if the Prop tool verifies if these frequencies match. Just guessing here. I'm sure Peters' binaries are good and it's just me doing something stupid.
    1042 x 616 - 183K
  • Congratulations! Now try blinking your LEDs! I think there is an LED blinking example that comes with Propeller Tool as well.
  • Propeller Tool has a bug wherein it can't reliably load large binaries over some types of USB-serial chip. I think the CH340G is one of those?

    IDK where to get one of the other loaders without having to compile it yourself though.
  • David Betz wrote: »
    Congratulations! Now try blinking your LEDs! I think there is an LED blinking example that comes with Propeller Tool as well.

    @David Betz Thank you, sir and no to the leds. I may try to load the biggest example provided with the prop tool instead to verify Wuerfel_21's theory above.

    @Wuerfel_21 Do you have any specific resource in mind you could direct me to ? These cheap converters do come at a price of debugging numerous problems but that is educational as well and a no go when you are in a hurry and need something reliable.
  • @Wuerfel_21 Thanks. I'll look into this PropLoader in detail tomorrow. At a brief glance I can see it's linux friendly so that's even better. If it works for me I'll look no further. After all I just need something to load Tachyon on the P1 and with that I'm all set, or so I think.
  • I feel strangely invested in this project. Good luck, @Maciek, we're rooting for you!
Sign In or Register to comment.