Forum Update - Announcement about May 10th, 2018 update and your password.

Weird Simple Ide problem

Power went out while working on a C project. Simple IDE can no longer find simpletools.h when compiling. I am using a new MAC computer. I have uninstalled and reinstalled Simple IDE and have the same result. ??????????????????
Is it a setting?

Comments

  • 10 Comments sorted by Date Added Votes
  • It also seems that there is no simple library or reference anymore. Perhaps there was an IOS update, and I hadn't restarted my computer yet. When the power went out it forced a restart. Now Simple-IDE and IOS are conflicting?
  • Have you tried reinstalling the Learn library Folder?
    Florida, between St. Petersburg and the Gulf of Mexico

    Do not look directly into laser with remaining good eye...
  • All I can see that one could do is update it. If I look at Library files, I can't see any .C files
  • Make sure your directories are set up correctly. Click on "Tools" and then "Properties" to see how the folders are set up.
  • I did that, I can follow simple libraries from the beginning to the end (the .C files). All of the .C files are light grey as if they aren't really there.
  • Here is what I see
  • I see the same list of files on my Windows 10 system. I don't know what a grayed out file on a Mac system means. Is the file really there, but you can't access it? How is that possible? Looks like you need help from a Mac expert.
  • I believe that an update took hold when I restarted my computer and there is now a compatibility issue. I emailed a bug report to Parallax.
  • It's possible that permissions on those directories and files have changed. (odd that)...

    Try this:
    1. In the macOS Finder, locate the Learn folder (most likely at: your-user-name/Documents/SimpleIDE/Learn
    2. Select the Learn folder and choose the "GetInfo" menu or type "Command-I"
    3. In the provided File Information dialog, select the little lock icon on the bottom-right (you will need your user password, here)
    4. Select your user name from the provided list of users and set Privilege to Read & Write (if not already set)
    5. Clock the gear icon at the bottom of the dialog box and select "Apply to enclosed items..."
    This should set the Learn folder an all enclosed files/folders to readable & writeable
    

    Let us know if this works for you.

    dgatelyblah.jpg
    407 x 853 - 74K
    Livermore, CA (50 miles SE of San Francisco)
  • Permissions were ok. After 3 days of playing around, I tried updating my workspace. Whatever I did, it worked.
Sign In or Register to comment.