Add another baud rate to PLX-DAQ

Hi

I have an older version of PLX-DAQ (older because my Excel 2003 can't handle the newer version).

The Baud rate selector in the version that I am using doesn't have the option of 115200. I need to know how to add this to the PLX-DAQ spreadsheet.

I understand that this can be done in VBA but I'm a newbie to this.

Any help will be really appreciated

Thanks

Comments

  • 3 Comments sorted by Date Added Votes
  • I've managed to open the VBA editor and opened frmStampDAQ.

    On UserForm I have added the following line:

    cboBAUD.AddItem ("115200")

    When I reload the spreadsheet and select 115200 from the Baud rate drop down box, I get -

    Run-time error "1000" Invalid port settings

    What else do I need to do to get it working?

    I hope you can help

  • I temporarily installed the PLX-DAQ software onto my Win7 laptop. I can't run the software due to missing some VBA object. Anyway I was able to look at the VBA source code and found the section you are referring to. Instead of adding a new "Additem" line, what if you just change one of the existing lines. For example remove the new line you entered and then change the "56000" entry to be "115200". See if that works.

    BTW, I'm assuming the PLX-DAQ software worked for you previously when selecting a slower baud rate.
    Along with 'Antimatter' and 'Dark Matter' we've recently discovered the existence of
    `Doesn't Matter`, which appears to have no effect on the universe whatsoever.
Sign In or Register to comment.