Forum Update - Announcement about May 10th, 2018 update and your password.

ELEV-8 with DXe radio ch6?

I have a new ELEV-8 v3 from the starter kit (#80335) that included a Spektrum DXe Tx and AR610 Rx. Upon following the build instructions, I don't see anything responding as ch6. I was able to bind the radio just fine, and when I plug in the USB connection and open ground station for the radio check, everything is set as I'd expect with the exception of ch6. I have tried the AUX switch, FLAP, and the bind/panic/trainer button and none of those appear to be mapped to ch6. I'm tempted to get a programming cable for the DXe anyway, and I'd expect that will give me additional configuration options. In the meantime, is there anything I'm missing?

I have completed the build and even flown a few times. The kit went together very well, and it is a joy to fly. I'm looking forward to adding some accessories and that is the reason for trying to pin down ch6.

Thanks!
Andy

Comments

  • 6 Comments sorted by Date Added Votes
  • The few documents out there for default setups for the DXe transmitter refer to channel 6 being the "Panic" button, which I believe is the Bind button. Does not make sense to me as they have other switches that are not mapped.

    I think a programming cable is in your future.:)
    Infernal Machine
  • Also, you are in the same time zone as Parallax. Give Tech Support a call. 888-997-8267 Miguel is familiar with the ELEV-8 and may have a DXe at his desk.
    Infernal Machine
  • Thanks, programming cable is on it's way. I may make a support call tomorrow, I'm away from the kit at the moment.
  • amcdawes wrote: »
    Thanks, programming cable is on it's way. I may make a support call tomorrow, I'm away from the kit at the moment.

    Did you get an answer for this?
    Infernal Machine
  • I just got the programming cable and yes I've now got things sorted out. It actually looks like I did a few things wrong along the way. The main mistake is that I ran a calibration in groundstation "radio settings" but didn't press the "bind" button when I should have. My guess is that made it appear to not work (because the two calibration values were the same). From that point on it appeared that ch6 wasn't working. Up and running now, I set ch6 to be the flap switch so I can have three values. That change does require programming the DXe. For the record, the default ch6 control was the "bind/panic/trainer" button. I feel like that point could be improved in the instructions.
  • Glad to see another Elev-8 pilot on here! ;-) Hope you get some good flights in with your new bird!
Sign In or Register to comment.