WX ESP8266 WiFi Module error: "RX handshake timeout"

OK, I got my WiFi module hooked up to a Propeller. I've switched it to STA mode and uploaded a little .binary file.
  • I sent a POST request to 192.168.50.29/propeller/reset and got a 200 status back, but the Propeller did not reset.
  • I then tried POST 192.168.50.29/propeller/load-file?file=2sblink.binary and got back status 400 and the message "RX handshake timeout" (and no reset).
  • Now if I POST 192.168.50.29/propeller/reset I get 400 and "RX handshake timeout"--and the Prop still does not reset.
I'm using the SIP version of the WiFi module. I've connected SIP pins 7-9 to the Propeller's PropPlug connector (I didn't bother with connecting GND to the PropPlug connector).

I think the first step is to get the reset working, so if anyone can help me out with that, I'd be grateful. Hopefully the handshake timeout will go away once reset works.

Comments

  • 5 Comments sorted by Date Added Votes
  • VonSzarvasVonSzarvas Posts: 1,269
    edited May 15 Vote Up0Vote Down
    Here are couple things....

    1. How do you have the Propeller connected to the WX module? You mention the PropPlug, but not the Propeller connections. In fact... you don't need to have a PropPlug connected at all, as the WX module replaces the PropPlug for programming the Propeller. Connecting the PropPlug to the WX module is only done to re-program the firmware in the WX module.

    2. If you are using the SIP connections, then you don't have the DTR pin available, which usually resets the Propeller before programming. You could use RTS instead- take a look in the WX module web gui, (or via the API), and change the reset pin from DTR to RTS. You'll find a drop-down in the webgui settings.

    Then the connections from the WX module SIP to your Propeller would be:
    WX VIN -> 3.3V
    WX RTS -> Propeller RESn
    WX DO -> Propeller RX (P31)
    WX DI -> Propeller TX (P30)
    WX GND -> Propeller GND -> Power supply GND 
    
    (Both devices must share common GND, else communications will be erratic or not work at all)
    

    With this set, you can get to the WX module web gui page, update the RTS setting, save to Flash, then experiment with your POST requests.
  • mparkmpark Posts: 1,167
    I did not have a PropPlug connected, but I completely misinterpreted the "Propeller Plug" marking under SIP pins 7-10 as meaning that those four pins should be connected to the Propeller as though they were a PropPlug. Anyway, I rewired as you suggested.

    I did not find anything in the settings gui to change the reset pin to use RTS; what I did instead was POST 192.168.50.29/wx/setting?name=reset-pin&value=15, then I clicked "Save to Flash" in the gui.

    And now it works! I can reset the Propeller remotely and run a .binary file. Thank you very much, @VonSzarvas!
  • mparkmpark Posts: 1,167
    Welp, I thought it was working. As it is now, when I power up the system with RES connected to RTS, the Propeller does not start and the WiFi module does not connect. But If I disconnect RES from RTS, everything starts correctly, and then I can reconnect RES and run a .binary. The WX's reset-pin is still 15.

    Of course I'd like everything to work without my having to disconnect RES every time I cycle power.

    Any ideas?
  • mpark wrote: »
    Welp, I thought it was working. As it is now, when I power up the system with RES connected to RTS, the Propeller does not start and the WiFi module does not connect. But If I disconnect RES from RTS, everything starts correctly, and then I can reconnect RES and run a .binary. The WX's reset-pin is still 15.

    Of course I'd like everything to work without my having to disconnect RES every time I cycle power.

    Any ideas?
    The RTS pin signals something during boot. Parallax uses the CTS pin for reset as an alternative to DTR. You might try that.

  • mparkmpark Posts: 1,167
    Thank you, @David Betz! I changed the WX's reset-pin to 13 and connected RES to CTS. Everything appears to be working now (of course I thought everything was working last night too, so who knows what problem I'll run into next).
Sign In or Register to comment.