Using SimpleIDE with a Propeller chip on a breadboard SOLVED

tw1tw1 Posts: 13
edited May 12 in Propeller 1 Vote Up0Vote Down
Hello,

I am completely new to the Propeller chip and would be very grateful for your help. I have a Propeller chip on a breadboard as per the datasheet circuit ( including 5MHz crystal, excluding EEPROM). I am using a 5V FTDI cable (with TX and RTS dropped to 3.3V) and an external 3.3V supply for the Propeller.

So far I have managed the following

Using Propeller Tool 1.3.2 - Change reset signal to RTS
Using Propeller Tool 1.3.2 - Successfully recognise hardware (Propeller one on COM5)
Using Propeller Tool 1.3.2 - Successfully Compile/Load/Run Parallax Serial Terminal Demo v1.0 (spin)

Sadly, I have not managed to replicate the above with the SimpleIDE using the demo Welcome.c Below is the build error rescue copy and paste. I would be grateful for any pointers as to where I am going wrong.

Best wishes,
Tristan

BUILD ERROR RESCUE COPY AND PASTE

Project Directory: C:/Users/tw/Documents/SimpleIDE/My Projects/

SimpleIDE Version 1.1.0
C:/Users/tw/Documents/SimpleIDE/Learn/Simple Libraries/
C:/Users/tw/Documents/SimpleIDE/ Updated on: 2018-05-12

propeller-elf-gcc.exe -v GCC 4.6.1 (propellergcc_v1_0_0_2408)
propeller-elf-gcc.exe -I . -L . -I C:/Users/tw/Documents/SimpleIDE/Learn/Simple Libraries/Utility/libsimpletools -L C:/Users/tw/Documents/SimpleIDE/Learn/Simple Libraries/Utility/libsimpletools/cmm/ -I C:/Users/tw/Documents/SimpleIDE/Learn/Simple Libraries/TextDevices/libsimpletext -L C:/Users/tw/Documents/SimpleIDE/Learn/Simple Libraries/TextDevices/libsimpletext/cmm/ -I C:/Users/tw/Documents/SimpleIDE/Learn/Simple Libraries/Protocol/libsimplei2c -L C:/Users/tw/Documents/SimpleIDE/Learn/Simple Libraries/Protocol/libsimplei2c/cmm/ -o Welcome.elf -Os -mcmm -m32bit-doubles -fno-exceptions -std=c99 Welcome.c -lm -lsimpletools -lsimpletext -lsimplei2c -lm -lsimpletools -lsimpletext -lm -lsimpletools -lm
propeller-load -s Welcome.elf
propeller-elf-objdump -h Welcome.elf
Done. Build Succeeded!

proploader.exe -r -I C:/Program Files (x86)/SimpleIDE/bin/../propeller-gcc/propeller-load/ -b activityboard -p COM5 Welcome.elf
Opening file 'Welcome.elf'
ERROR: Download failed: -1

Opening file 'Welcome.elf'
ERROR: Download failed: -1

Comments

  • 5 Comments sorted by Date Added Votes
  • SimpleIDE defaults to DTR for the reset signal, as that's what the Parallax PropPlug needs.

    But you are using RTS with your FTDI cable.

    So my Did you go into SimpleIDE / Properties / General tab and set the Reset Signal dropdown menu to "RTS" ?

    Press F6 when SimpleIDE is open, to bring up the Properties window.

    If that's not the issue... do you have some other program doing something on your COM5 at the same time? Maybe SimpleIDE cannot get access to the port.


  • Hello VonSzarvas,

    Thank you for your post, with your help I have moved on a little.

    I did change the reset signal to RTS in the properties tab of SimpleIDE, and I do not think there is a COM5 conflict, certainly not one that concerns Prop Tool.

    However, if I unplug my USB adaptor and let SimpleIDE search for new COM ports, I can successfully Compile/Load/Run in SimpleIDE - but only once. I have to unplug/re-plug in the adaptor to perform another Compile/Load/Run.

    I do not have to unplug at all in Prop Tool to Compile/Load/Run repeatedly.

    I have uninstalled the FTDI drivers and reinstalled them, but the situation remains the same.

    Any further ideas really appreciated, though on the plus, I have written my first program in spin.

    Kind regards,
    Tristan




  • tw1tw1 Posts: 13
    edited May 12 Vote Up0Vote Down
    SOLVED

    Hello VonSzarvas,

    Thank you for pointing me in the direction of the COM port. I needed to reconfigure the COM port itself for my particular setup.

    The "Set RTS on Close" option needs to be checked within the "Advanced Settings" for the COM port.

    On Window 10, navigate to Ports (COM & LPT), select the USB Serial Port in question, Port Settings Tab, Advanced.

    "Set RTS on Close" checked seemed to be the difference between repeated successful Compile/Load/Run in SimpleIDE with my setup. No unplugging/re-plugging.

    Many thanks,
    Tristan
  • Awesome.

    Thanks for sharing your solution Tristan.

    Happy creating!
  • I spoke too soon... Progress rather than solved. On my setup checking "Set RTS on Close" also interferes with the normal operation of SimpleIDE Terminal. More thinking required!
Sign In or Register to comment.