NodeMCU SPI Module too fast


I really want to make use of the SPI module on my NodeMCU. SPI keeps my code clean and frees up some of my GPIO pins. I feel it is sending data too fast for my 74HC595 to keep up with. It was working for a bit, then stopped.

It seemed like there was a lot of noise on the line so I hooked up the logic analyzer and saw that when I was sending data, bits were flying across the line at almost 6 ns (which is awesome). I am driving a 595 and ultimately a stepper, that need data at a way slower rate. I have tried using the clock parameter in the setup call, I feel it never slows the SPI clock.

Here is the datesheet of 74hc595

Is there any way to set the clock speed to something that would be more 595+stepper friendly?


ModEdit: Moved to General category

Comments

Sign In or Register to comment.