Need help setting up port forwarding for my Spinneret

I loaded in MikeG's server program which works great locally on my network. Now I am trying to access it outside of my network.

Here's the details- Frontier (formally Verizon) DSL using a Westell 7500 DSL Modem / Router
Using "whatsmyip" website I come up with 50.103.18.208
I have my Spinneret set for 192.168.1.120 port 5000

Where I get stuck is configuring my router for port forwarding.

Here's a series of screenshots:

First it asks me to select a service or rule
Screen shot 2011-09-26 at 5.33.37 PM.jpg


from this long pull down list:
Screen shot 2011-09-26 at 5.34.39 PM.png


Screen shot 2011-09-26 at 5.35.09 PM.png


I selected to make a new rule and named it Webserver. I assigned it to port 5000 as you can see in the last screenshot. I don't know what they mean by "Base Host Port" so I put in 5000
Screen shot 2011-09-26 at 5.35.47 PM.png


So I try to connect through my Android phone and it comes up with web page not available. It is still ive if anyone wants to try it.

Any suggestions?

Don M
Tagged:
«1

Comments

  • 31 Comments sorted by Votes Date Added
  • edited September 2011 Posts: 0Vote Up0Vote Down
    It works for me. I get a "Hello World" page and an LED page. The LED on:off thing doesn't seem to do anything, though.

    -Phil
    “Impossible is just a big word thrown around by small men who find it easier to live in the world they’ve been given than to explore the power they have to change it. Impossible is not a fact. It’s an opinion. Impossible is not a declaration. It’s a dare. Impossible is potential. Impossible is temporary. Impossible is nothing.” –Muhammad Ali
  • edited September 2011 Posts: 1,366Vote Up0Vote Down
    Hmmm. Thanks Phil. I haven't done much else with the webpage code yet. Was going through Mike's excellent tutorial.

    Wonder why it won't work on my Android phone and tablet....
  • edited September 2011 Posts: 0Vote Up0Vote Down
    Did you remember to put the ":5000" after the IP address?

    -Phil
    “Impossible is just a big word thrown around by small men who find it easier to live in the world they’ve been given than to explore the power they have to change it. Impossible is not a fact. It’s an opinion. Impossible is not a declaration. It’s a dare. Impossible is potential. Impossible is temporary. Impossible is nothing.” –Muhammad Ali
  • edited September 2011 Posts: 1,366Vote Up0Vote Down
    Yes. Exactly as you have it. No go.
  • edited September 2011 Posts: 0Vote Up0Vote Down
    Maybe your wireless service blocks non-standard ports.

    -Phil
    “Impossible is just a big word thrown around by small men who find it easier to live in the world they’ve been given than to explore the power they have to change it. Impossible is not a fact. It’s an opinion. Impossible is not a declaration. It’s a dare. Impossible is potential. Impossible is temporary. Impossible is nothing.” –Muhammad Ali
  • edited September 2011 Posts: 0Vote Up0Vote Down
    Worked fine from my Netbook running Ubuntu w/ Netscape, worked from my iPad w/ Safari BUT it did not work from my iPhone with Safari. The Netbook is on my home network and the iPhone is being stubborn tonight and going 3G. My iPhone just connected to WiFi and it still gets no connection. iPhone says "server stopped responding"

    Information...just maybe not helpful information!
    MOV OUTA, PEACE <div>Rick </div><div>"I've stopped using programming languages with Garbage Collection, they keep deleting my source code!!"</div>
  • edited September 2011 Posts: 1,366Vote Up0Vote Down
    My tablet is Verizon Wireless and my phone is US Cellular.

    Can someone else try with their cell phone or tablet?

    I can see the requests coming through. Neat.
  • edited September 2011 Posts: 0Vote Up0Vote Down
    With you 'droids connected to your local network (home WiFi) can the get to it via the 192.168.x.y address on port 5000?
    MOV OUTA, PEACE <div>Rick </div><div>"I've stopped using programming languages with Garbage Collection, they keep deleting my source code!!"</div>
  • edited September 2011 Posts: 0Vote Up0Vote Down
    Don,

    If you try to access the Spinneret through WiFi, rather than through the cell network, you will probably have to use the local LAN address instead of the internet address. At least that's the way things work on my LAN. If I want to test outside connectivity, I have to set up a proxy on an outside server to forward the request to my local system and echo the response back to me.

    -Phil
    “Impossible is just a big word thrown around by small men who find it easier to live in the world they’ve been given than to explore the power they have to change it. Impossible is not a fact. It’s an opinion. Impossible is not a declaration. It’s a dare. Impossible is potential. Impossible is temporary. Impossible is nothing.” –Muhammad Ali
  • edited September 2011 Posts: 1,366Vote Up0Vote Down
    Ahhh. That brought up a point... I forgot I had the tablet connected to my WiFi. I turned off the WiFi so it would connect to 3G. It pulled the page up just once but is not reliable. Comes up with "Server failed to communicate" message.

    The cell phone was not on WiFi though.
  • edited September 2011 Posts: 1,366Vote Up0Vote Down
    Phil- you said a mouthful there... not sure what you are talking about. Care to give some detailed pointers?

    The tablet will access it fine on WiFi with the local address.
  • edited September 2011 Posts: 0Vote Up0Vote Down
    If you access a node in your LAN from somewhere else in your LAN (e.g. via WiFi), you probably have to use the node's local address. IOW, the router won't do an out-and-back from the internet without an external point to connect through. A proxy is such an external point on the internet that simply forwards requests and responses. Google "open proxy", and you will find an abundance of them.

    -Phil

    Addendum: For your purposes here, use of an unknown open proxy is probably benign. For other purposes, such as sending email, passwords, etc., most open proxies cannot be trusted not to steal private information.
    “Impossible is just a big word thrown around by small men who find it easier to live in the world they’ve been given than to explore the power they have to change it. Impossible is not a fact. It’s an opinion. Impossible is not a declaration. It’s a dare. Impossible is potential. Impossible is temporary. Impossible is nothing.” –Muhammad Ali
  • edited September 2011 Posts: 1,366Vote Up0Vote Down
    When I try to access it via cellular I get a timeout message on the cellular device webpage but I also can see on PST that something is trying to access the server. I get a FIFO[0] 00000000
    *Timeout* error.

    The Request count does not advance at that point but instead posts a duplicate. Maybe there is a timeout variable that can be tweaked?
  • edited September 2011 Posts: 1,366Vote Up0Vote Down
    Someone keeps trying to GET / favicon.ico but it produces a 404 error on PST.
  • edited September 2011 Posts: 0Vote Up0Vote Down
    All modern web browsers will attempt to GET /favicon.ico. Don't worry about it. What it is is the little icon that appears in the browser's tab next to the site title, like this one for the forum: favicon.ico. If you don't have one, just send an HTTP 404 response, and the missing icon will be ignored.
    “Impossible is just a big word thrown around by small men who find it easier to live in the world they’ve been given than to explore the power they have to change it. Impossible is not a fact. It’s an opinion. Impossible is not a declaration. It’s a dare. Impossible is potential. Impossible is temporary. Impossible is nothing.” –Muhammad Ali
  • edited September 2011 Posts: 1,366Vote Up0Vote Down
    I can see the request come from the cellular device on PST but for some reason it times out before the cellular device receives an answer (just my guess here).
  • edited September 2011 Posts: 0Vote Up0Vote Down
    Don,
    It works from my android 2.2 casio commando smart phone with verizon
  • edited September 2011 Posts: 1,366Vote Up0Vote Down
    @mojorizing- try it again a few times. Thanks.
  • edited September 2011 Posts: 0Vote Up0Vote Down
    I did it a number of times - via my wifi and verizon's 3G . No time outs. What version android are you using?
  • edited September 2011 Posts: 1,366Vote Up0Vote Down
    Android 2.2 on both of my devices. I see someone got a few timeout errors. I also saw quite a few successful requests too.
  • edited September 2011 Posts: 0Vote Up0Vote Down
    Mindrobots had a good point...you should be able to connect to the 192.xxx.xxx.xxx inside your network without going on the 'net.

    I have a westell dsl modem...it has a lot of utilities/tools for logging...is that what you're using for traffic analysis?
  • edited September 2011 Posts: 1,366Vote Up0Vote Down
    Yes I know I can do that and it does work if I enable WiFi on my Android devices.

    But I was trying to access the Spinneret from outside my local network. Using my Android devices on a cellular network is the only way I can without connecting through someone else's network.
  • edited September 2011 Posts: 0Vote Up0Vote Down
    I can NOT connect over 3G with my Android using http://spinneret.servebeer.com:5000/. I get a "Web page not available" error message. But I can connect if enter my WAN address and port.
    Any fool can make something complicated. It takes a genius to make it simple. Woody Guthrie
  • edited September 2011 Posts: 0Vote Up0Vote Down
    Mike,

    Do you think your cell provider might be blocking port 5000? What happens if you configure your router to forward external requests for port 80 to your server on port 5000?

    -Phil
    “Impossible is just a big word thrown around by small men who find it easier to live in the world they’ve been given than to explore the power they have to change it. Impossible is not a fact. It’s an opinion. Impossible is not a declaration. It’s a dare. Impossible is potential. Impossible is temporary. Impossible is nothing.” –Muhammad Ali
  • edited September 2011 Posts: 0Vote Up0Vote Down
    What happens if you configure your router to forward external requests for port 80 to your server on port 5000?
    Set the router to forward port 80 traffic - no dice on http://spinneret.servebeer.com. Worked in Firefox.

    Tried my WAN IP http://68.99.244.218 - no dice.

    Set the router back to forward port 5000 traffic and http://68.99.244.218:5000 works but not http://spinneret.servebeer.com:5000/. I guess it has something to do with the host redirect.

    WiFi always works.
    Any fool can make something complicated. It takes a genius to make it simple. Woody Guthrie
  • edited September 2011 Posts: 0Vote Up0Vote Down
    Tried to hit http://50.103.18.208:5000/ and received the following error over 3G.
    Data connectivity problem
    The server failed to communicate. Try again later.

    WiFi works fine though.
    Any fool can make something complicated. It takes a genius to make it simple. Woody Guthrie
  • edited September 2011 Posts: 1,366Vote Up0Vote Down
    Mike- What do you think causes the problem through the cellular networks?
  • edited September 2011 Posts: 0Vote Up0Vote Down
    No idea... but it presents a great opportunity for someone to figure it out.
    Any fool can make something complicated. It takes a genius to make it simple. Woody Guthrie
  • edited February 2012 Posts: 0Vote Up0Vote Down
    I have the same problem... It actually works, but, maybe only 1 out of 10 times - though the tx and rx lights flash every time.
  • edited February 2012 Posts: 0Vote Up0Vote Down
    access via cell-phone (3g etc) will most likely be blocked by your carrier to stop malware etc. it is on orange (uk) as my site doesn't work on it either, unless on port 80.
Sign In or Register to comment.