PDA

View Full Version : Proto Board + Prop Plug <> Joy



mpark
09-13-2007, 09:39 AM
I just got a batch of proto boards and I can't get my PC to see them (I've tried two).

This is the same PC I use with my Hydra. I unplugged the USB from the Hydra and plugged it into a proto board. Hit F7 in the IDE and... "No Propeller chip found on any COM port".

I don't know if this is significant, but the Hydra (when connected) is on COM 5; the proto board is coming up on COM 6.

I'm running XP Home and version 1.05.5 of the IDE.
I reduced COM 6's latency from 16 to 1.
I tried different USB cables in different USB ports.
Proto board is on.
The prop plug is supposed to be logo side up, LEDs down, right?

Can anyone help me out here?

Fred Hawkins
09-13-2007, 09:20 PM
I can't help you but I can add to this thread's question list :)

I tried using a little ohm meter (Lafayette el cheapo from Radio Shack circa 1970) to read a proto board's propplug pins back to pin 31. My problem is that it didn't matter which of the four pins I tried, they all said low resistance. And in fact, any of the numbered holes around the prop chip to the any pin on the propplug right angle header gave the same low reading. Nothing looked like an open except when I tried the propplug to an unused prototyping hole.

So two questions:
1) can you use an ohm meter (powered by one AAA battery) on a proto board?
2) what sort of result should I expect? (maybe my antique meter won't be terribly useful.)

I hope REV B of this board marks the propplug orientation. And the pdf too.

bambino
09-14-2007, 04:37 AM
mpark,
Looking down on the Protoboard, the Propeller Logo is facing up on my setup at home, and is working.
One Problem I have is that I am using it as a debug line in my program(Programmed in the eeprom), and opening the com port early in the program ment that when I would power the Proto board and hit F10 the signals would collide and cause the IDE to show Propeller not found. I placed a delay before opening the Com port from the Prop and it worked. Don't know if this is your case , but hope it helps!

mpark
09-18-2007, 08:10 AM
Problem resolved. Parallax sent out a new Prop Plug and it works perfectly.

Too bad about the faulty one, but a big thank-you to Parallax for excellent customer service.

Post Edited (mpark) : 9/18/2007 1:20:17 AM GMT