PDA

View Full Version : Won't repeat...



James Newman
09-03-2007, 07:29 AM
I've just started trying to learn propeller asm, but ran into a problem.

I whipped up a simple led flashing asm program, rna it, but it kept ending prematurely. I thought this was in the asm, so I played with it and eventually figure out it was the spin driver program ending. I had a repeat at the end, to repeat forever, so I played with it, add some code to it, and it still only executes once.

Finally, I went and tried programs I had already ran before, not a single one will repeat, even though they where all working just before this. I unhooked the battery from the propeller and tried again... nothing. I'm loading strait into ram, so it's not anything in the eeprom.... any ideas? I would post some code, but the current problem is, no 'repeat's repeat!

Areal Person
09-03-2007, 07:33 AM
Make sure your 3.3 volts power supply is 100% correct, slightly low voltage can cause
it to not repeat.

-Areal

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
I have a tree growing out of my head, but

what do you expect ? I'm a programmer.

James Newman
09-03-2007, 07:39 AM
After restarting the ide, and the computer, still persisted. I noticed that that it repeated 3 times after restart, then once after. Changed the battery and wolla. So, yep lack of 3.3v supply due to drained battery, thanks.

Man, and after I butchered my asm code thinking it was broken.