PDA

View Full Version : Help getting started - er' re-started.



jmwither
04-23-2007, 08:23 AM
My daughter has a project for school and we need to make a top hat with chasing LEDs around the top.
Simple enough for a BS revD and I still have two of em in my kit box.

I haven't used the Basic Stamps for years. So I dug it all out.· Two BS revD and one BS2 on a super carrier board·and the·parallel to 3pin comm cable.
I then·went to Parallax website and downloaded the latest IDE SW v2.2.6

I installed SW on my laptop (IBM thinkpad), connected the comm cable, snapped in a new 9v batt, loaded a program from the samples folder and tried to download and I get error "No BASIC Stamp Found".· The Identify does'nt seem to find anything either.

I've been looking for trouble shooting info for getting started and haven't found it yet.

I've tried all three BS modules.·Tried it from·two different laptops and one desktop pc.

My comm port config is BPS: 9600, DB: 8, Parity: None, SB: 1, FC None.·

Any hints or tricks on what to do next to get this running.

Thanks,
- Mike

Forrest
04-23-2007, 08:37 AM
FYI the Windows version of the Basic Stamp IDE requires the Basic Stamp 1 serial to 3 pin adapter sold here www.parallax.com/detail.asp?product_id=27111 (http://www.parallax.com/detail.asp?product_id=27111)

Parallax stopped supporting the DOS version of the Basic Stamp IDE (which used a Parallel to 3 pin adapter) many years ago, though if you kindly ask the Parallax support staff they may email you a copy.

I don't reallyknow why the BS2 is giving you trouble, though laptop serial ports have been problematic for some users. If you're laptio is running on battery power, try it again with the power adapter plugged into AC.

jmwither
04-23-2007, 08:56 AM
Thanks,

I'll have to go with the USB to serial, as my laptop has no serial port.

allanlane5
04-23-2007, 10:04 AM
Well, the Belkin USB to Serial adapters haven't worked too well.
Parallax sells an FTDI-based adapter that works, and the KeySpan 19q works well also.

If the adapter is for "PDA"s, it usually doesn't support all the 'handshake' lines with proper timing. Which the BS2 needs.

mashersmasher
04-23-2007, 10:19 PM
check the battery? sometimes if there duds the led will go on but the board won't be recognized. also check the cable. i used one off my palm 3 and it didn't work. sorry i'm a newb