PDA

View Full Version : New versions of the documentation (Basic Stamp Progr. Manual 2.2) apply to whic



Skywalker49
04-06-2007, 03:37 AM
I don't know how to find out what the difference is between my BS2
and the one mentioned in the Basic Stamp Progr. Manual 2.2.

One thing is sure, I tried some of the new commands and those
don't work!

The 2.2 manual says that it applies for BS2 firmware 1.0 and
windows interface 2.2.

When I run Basic Stamp Editor .. Identify, I get version 1.0.
I assume this is the firmware version.

Where to find the Windows Interface version ?

Thanks,
Ed

Mike Green
04-06-2007, 03:44 AM
From the main page of Parallax's website, choose the Downloads menu item, then the Basic Stamp Software submenu. On that page you will find the latest Stamp Editor (version 2.2.6). Some of the statements described in the manual don't apply to the BS2. These are clearly marked either in the margin or on the first page describing each statement.

Even with the latest editor, you have to specify which form of the syntax you're using (with a compiler directive in your source program). The default is the older (2.0) version. It's very clearly documented.

Skywalker49
04-06-2007, 03:54 AM
Mike,

I'm using 2.2.6 but missed the PBASIC directive. Often it doesn't matter but in this case (some DEBUG option) it does.
Thank you for pointing me in the right direction .. directive :<)))

Ed

Chris Savage
04-07-2007, 04:00 AM
If you don’t specify PBASIC 2.5 the Editor will assume PBASIC 2.0 for compatibility. It is recommended on newer programs to always insert the PBASIC 2.5 directive to take full advantage of the PBASIC language. Take care.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Chris Savage
Parallax Tech Support