View Full Version : emic text to speech module

03-15-2007, 12:09 PM
is there anyone who has worked with the emic text to speech module. we are using it for our project, but we are not sure of the connections for interfacing it with a micro controller. if anyone has worked with it before could you please send us the circuit diagram of the connections. we are giving digital data via the micro controller, which is in the form of ascii text ....and the module converts it to audio which is then connected to an speaker......

Peter Verkaik
03-15-2007, 12:31 PM
See the manual on how to connect the module.

regards peter

03-15-2007, 12:41 PM
thankyou sir... infact i have this data sheet of the module, but we would like to check how the module works, that is by interfacing with the computer . but we dont know how we are to enter the text via hyper terminal? is it ascii or hex codes? then we also dont know if we have to use any other software inorder to work the module,when we are using the hyper terminal? we wanted to check how the module gives the audio out put, and what is the default volume of the audio produced when the text is read out from the module, will it be loud enough if we use the A out pin, or do we have to use a seperate speaker?

Peter Verkaik
03-15-2007, 01:15 PM
You cannot connect the module directly to a pc serial port.
The module uses TTL level (0V and 5V) signal level. The pc uses
RS232 (-12V and +12V) signal level.
You must either use a microcontroller or a levelshifter such as max232.
The Aout is a line level audio signal that must be feed into an amplifier via
a capacitor. You can connect a 8 ohm speaker (0.25W) directly between
SP+ and SP-.
You can use hyperterminal using ascii, provided you use the max232·chip.

regards peter

Chris Savage
03-15-2007, 09:30 PM
Are you planning on using the Emic with a Javelin? Your first post indicates you wanted to connect it to a microcontroller but then you said you wanted to connect it to a PC. This is not the correct forum for that subject if this is the case.

Chris Savage
Parallax Tech Support

03-16-2007, 12:20 PM
sir, we hav bought the emic tts module.We would like to connect it to a microcontroller preferably to an AT89C51 for our project. but before that we would like to test the module to see whether it is in working condition.we tried connecting it to a hyperterminal but it didnt work.The module was showing the green LED throughout after initialisation.
In the hyperterminal we had given
as such.This was connected via the RS232 and MAX232.We had connected an 8 ohm speaker b/w pins SP+ and SP-.The other pins we used were Vcc,gnd (8,11),SIN ,SOUT.

is there any other method to test the module?

Chris Savage
03-16-2007, 10:28 PM
This thread is being moved from the Javelin Forum to the Sandbox Forum.

Chris Savage
Parallax Tech Support

03-18-2007, 11:57 AM
could u please direct me t othe correct forum, in that case....i really need help regarding the module.

03-18-2007, 05:20 PM
Just off the top of my head, do you have Transmit (TX) from the PC going to Receive (RX)·on the EMIC chip?·

At only·ONE place in the chain, you need to flip RX and TX.· (The same effect as a null-modem cable).· You can do this where the PC connects to the MAX chip or between the MAX chip and the EMIC.· Alternately,·try using a null-modem cable between the MAX and PC.

Where is power for the MAX chip coming from?· If not from the same supply as the EMIC, then you need to connect the VSS·of your power supplies together.· Did you connect the common wire from the PC serial port·to the MAX chip? (Or it may need to go to VDD, but double check me)

Double check the baud settings, Hyperterminal should be set to 2400, 8, N, 1.

Check SW1 on the EMIC, make sure it's·on, so that your data should be sent as·ASCII.· If off, data should be sent in hexadecimal.·
Temporarily set SW2 on.· All the commands you send should echo back to hypterminal.· This will allow you to test the serial connection.· Turn off when working properly.

Volume is software controlled.· Try increasing it before sending the first·speak command.· "Volume=7;"· (Max Volume)

Try ending all of your commands with a ";" (semicolon).· "Say=hello;"

I hope this helps!

Post Edited (Desy2820) : 3/19/2007 10:03:53 AM GMT

03-20-2007, 08:54 PM
thanks a lot we tried with the hyper terminal..and it worked..... well we did it in the default mode, did not change the volume or the pitch...anyways was really happy to hear the voice coming out of it...:)