PDA

View Full Version : Prop and the VDIP1



TonyZ
02-16-2007, 02:11 AM
Hey all,
I have the VDIP1 and am having difficulty getting it to communicate the my propstickusb in sdi or uart mode.

I have the jumpers set right.·I can programmatically reset the device. The little green leds blink etc. so I am fairly confident it's ready to talk to.

I have done·my usual·trouble-shooting walkthru; check the wiring,pins,jumpers, check the documentation (which·I find to be confusing with the viniculum·device, so I looked at all the v docs to figure out which one matched the vdip1). I have switched the rx and tx pins around incase i got that wrong, etc.

In the forum I found:
http://forums.parallax.com/showthread.php?p=619886

I have tried sdi mode with Mike Green's code, but no luck there.
I guess because the doc shows 4 wire spi and Mike's code uses 3 wire and I don't know enough about it to make that work.
I have read that Chris Savage was able to get it to·work in UART mode with a few thumb drives.

I only code example i have for UART mode is·looks like it's for the Vdrive not the Vdip, it looks like with some minor command value changes it would work, but still doesn't.
If you have gotten the·vdip1 to work with the prop, I would appreciate any help you could offer.

Chris, when you get a chance, could you please show me·a code snippit that might help? (it doesn't have to be·official parallax code, anything would be great)

Thanks a lot


Post Edited (TonyZ) : 2/15/2007 7:44:52 PM GMT

Mike Green
02-16-2007, 03:14 AM
In serial UART mode, make sure CTS# is pulled up to +3.3V with a 4.7K or 10K resistor. The VDIP1 won't transmit to the Propeller if this isn't so.

I noticed that the Vinculum chip doesn't send and receive at the same time in SPI mode so DI and DO can be connected to the same Propeller pin to save a pin.

Chris Savage
02-16-2007, 06:18 AM
Tony,

My code examples were for the BASIC Stamp. Mike was working on the Propeller code for the VDIP. What interface were you hoping to use? SPI or Asnyc-Serial?

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Chris Savage
Parallax Tech Support

TonyZ
02-16-2007, 06:21 AM
Thanks Mike,
I tried what you suggested, no improvement however.
Maybe I am doing this all wrong.
Here's where my brain is at: I assumed that I could plug in my thumb drive into the existing usb connector and issue commands to the vdip1 module thru pins 6(txd) 8(rxd) 9(rts#) and 10(cts#) to do fileio to the drive.
Is this correct at all?
If so the uart code I have seen in this forum didn't mention using pins 9 or 10.
The vdip seem to be completely ignoring the prop tx. The vdip is (according to the docs) transmit version information upon startup, i don't see any data on pin 6 at start up.
I am really stumped.
Arrg.

Joe McClure
02-16-2007, 06:33 AM
Hi Chris,
I have the same problem.
I was hoping to use·Asnyc-Serial. If no other reason than it seems simpler to me.
·

TonyZ
02-16-2007, 11:37 PM
Chris,
I wanted to use it in UART mode but anything at this point would be ok. UART preferred.
Am I way off on wanting to use the vdip1 the way I described above?

Thanks

TonyZ
02-17-2007, 10:12 AM
Hey again,
Do you think maybe it's a 3v to 5v logic level·problem?

Thanks

Mike Green
02-17-2007, 10:36 AM
Tony,
I had no problem talking to a VDIP1 using a Stamp in UART mode. I only tried using the Propeller in SPI mode and that worked. Make sure you're powering the VDIP1 from a +5V supply. It needs that for USB power.

I just plugged the VDIP1 into my Propeller Demo Board and connected pin 1 (5V) to +5V, pin 6 (AD0) to P1, pin 7 (Gnd) to Vss, pin 8 (AD1) and pin 9 (AD2) to P2, pin 10 (AD3) to P3, and pin 22 (RS#) to P0. The jumpers are set for SPI use. The routines I posted (attached here) worked with this.
Mike

TonyZ
02-17-2007, 12:11 PM
Awsome,
It's working! (SPI -gave up on UART)
You know I tried that setup the first time I saw your advice and it didn't work.
I obviously screwed something up. I am such a knuckle head. But a happy one.
Thanks Mike, you rule man. There should be points you can give people for helping.
You'd get 100 (out of 100)

Tony