PDA

View Full Version : vmware and PropSTICK USB



Thetawaves
01-31-2007, 05:17 PM
Have there been any reports of Windows XP running on vmplayer where the propeller IDE and USB link works?

In my experience with uc dev, the link between the host os's serial ports, and the vmware client os's serial ports doesn't work. I have however, heard that usb in vmware works very well, for example, a usb-rs232 converter can be used to control the serial port. I would like to skip serial ports all together and use the easier usb standard/physical interface.

Do the propeller IDE and programming software/drivers work well with vmware usb support? I don't expect parallax to have investigated this, but are there any hobbiests who have tried this configuration?

Remy Blank
01-31-2007, 07:38 PM
I have tried, the IDE works, the USB interface is detected, but you get a timeout when you download the code about 19 times out of 20. For short programs. If you are lucky. If you're trying to upload to the EEPROM, no chance.

So in short, it almost works, but there is a timeout in the Propeller bootloader that is very difficult to avoid if you have several layers between the IDE and the USB port. Unfortunately this is difficult to solve because, well, the bootloader is hardcoded in the chip.

-- Remy