PDA

View Full Version : 2 computers hooked up to one Prop--solved maybe



T Chap
01-30-2007, 06:03 PM
I have a PC laptop connected via USB2serial to the programming port on a custom Propeller board. The port is the typical RS232>MAX3232>Prop to pins 30 and 31. I want to write and update code on the Propeller, and test the code that runs serially from a Mac via USB2serial on pins 13,14 using the Full Dup Obj.

I can program the Propeller no problem from the PC, then pull the USB2serial adapter, plug it in the Mac, and run the motors via the Mac program. But because there is a ton of code and testing left, I wanted to not have to change cables everytime, so I left the PC on the main programming RS232 defaulting to pins P30 P31. I put the Mac USB2serial adapter TX, RX and Vss to P13 and P14, tied GND's together. I set Full Dup to run:

ser.start(13,14,0,9600)

When the program runs on the Propeller, it sets P8 high as the motor driver enable, so on typical boot up or F10/F11, you always hear the motors reset to a steady PWM noise/hiss. The problem is when using the new setup with the Mac and Full Dup on P13 and P14 as shown, the motors will reset but the Prop is going to some unknown mode and the motors default to off. If I set the ser.start back to P30/31, the motors come back on meaning P8 is high again(motor enable). If I hit F11 with Full Dup at P13 and 14, and pull the PC completely, then reboot the Prop, it still doesn't run with the Mac or PC plugged or unplugged. If I comment out the ser.start, the motors run so I suppose the problem is related to that, although it makes no sense to me.

******* Progress at 3am: The USB2ser adapter Tx sits at -8.5vdc. The serial object needs to see a 1 I believe, I forgot this new Tx and Rx set will need a MAX3232 as well! *******

Post Edited (originator) : 1/30/2007 11:07:18 AM GMT

inservi
01-30-2007, 07:14 PM
Hello,

As you explain, it is very strange. Could you join a schematic draw and a piece of code.

So, the problem look like it is an interaction between the pin 8 and the pins 13 and 14 ?
Witch serial object do you using ?

Best regards,
dro

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
in medio virtus

bassmaster
01-31-2007, 05:41 AM
this "custom propeller board" sounds like it may have a short, I have been guilty of such issues. 8 is real close to 9 and I am sure 9 should be ground, get a good glass and look for shorts, if you socketed the prop and eeprom, pull them and scope resistance on each lead. Its possible your code could have an issue also, I ran into someones code I downloaded a few weeks ago here that had a "START (PIN in the test program,.... but it also had hard coded pin usage in the object.... also could be in assembly somewhere.