PDA

View Full Version : Suddenly a "No Basic Stamps Found" message start to appear....



ProServ Engineering
01-15-2007, 03:25 AM
I'm working with the Boe-Bot kit and got stuck now at the centering exercise for the servos. After I centered the first one and adjusted the pot to stop rotation, when tried to run the program offered in the manual to center the second servo the system started to give the error message mentioned in the subject above...I don't know what may be happenning, below is what I tried so far;

1. the basic stamp is a BS2 Rev. G, I put a BS2sx I have as a spare·to the·board and still the same error,

2. installed the BS2 Rev. G onto another board, Rev. C and still the same error, (both boards, the one at the robot and the other one I have as spare are Board of Education Rev. C),

3. switch servo wires and still the same error,

4. installed the other spare board onto the robot chassis ans still the same error,

5. delete·and re-install USB-to-serial adapter driver and still the same error,

6. delete and re-install PBASIC software and still the same error,

When I run the Identify option from PBASIC, there is no version displayed but the Loopback and Echo are both returned as a "Yes" on COM 4 (COM 4 has always been the one I have been using)

Please help, the same error happens in the·2 boards I have and with either of the 2 Basic Stamps I have. Both boards and stamps were working OK, all start to fail after I adjusted the pot for one of the two servos for the Boe-Bot....PLEASE HELP!!!!!

Phil Pilgrim (PhiPi)
01-15-2007, 03:34 AM
Try a different serial cable. The one you're using might have an intermittent open on the DTR line.

-Phil

allanlane5
01-15-2007, 04:27 AM
Amazingly enough, the one thing you've failed to mention is how you are powering this. Intermittent "can't connect" messages can come from low power. This is more likely, since servo's use quite a bit of power too.