PDA

View Full Version : Basic Stamp Editor for Windows 95?



Bobalou
01-14-2007, 07:04 AM
I've been working quite well with my recently acquired BOE on an XP computer. Works well using both the serial and the USB connections. However, I was hoping to be able to also use an old laptop I have which is running the Win 95 OS. The download page does not say that v.2.2.6 will run on 95 (although it doesn't say it won't either.) I assume by it's abscence in the list of approved OS's that I might need an older version. Does anyone know how I can do this?

Thanks,
Bob

Bruce Bates
01-14-2007, 04:01 PM
Bob -

The latest versions of the PBASIC Stamp Editor will only work with Windows XP. Older versions (if you can find them) will work with earlier operating systems.

As you go back in versions you lose more and more features however. Thus the latest edition will always be the most complete edition.

Regards,

Bruce Bates

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
<!--StartFragment -->

Forrest
01-14-2007, 08:26 PM
I've successfully used version 2.2.5 under Windows 98SE with no problems. Note Parallax didn't support this configuration. My only other comment is that while some later version of Windoes 95 did support USB - it wasn't very reliable and most software makers didn't support it.

Bobalou
01-15-2007, 04:16 AM
Thanks, Bruce and Forrest. I downloaded the v 2.2.6 which I'm using on my XP computer, from the parallax web site. I've checked the CD which came with the BOE kit, and it seems to have v 2.2. Perhaps that will work. I'll give it a try.

I don't normally use a laptop, but this is an old one that my wife got for using only for word processing. Turns out she really wanted more than that, so she got a newer laptop. I've been using the old to run a freeware Astronomy program, when I go somewhere with my telsescope.

I'll have to use the serial connection since it doesn't even have a USB. In fact it doesn't even have a CD drive, so I'll have to copy the BS Editor onto an external zip drive I have (just for transporting stuff into the laptop) and transport it that way.

I'll repost with any results I get.

Thanks again,
Bob

stamptrol
01-15-2007, 10:53 PM
I've got two old W95 machines which I use for field work with the stamps. The revision level of the programming software is 2.2. something that I loaded last year some time.
I can confirm that W95 support of USB is pretty poor, so the serial port is the way to go.

Cheers

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Tom Sisk

http://www.siskconsult.com

Bobalou
01-16-2007, 10:40 AM
Tom Fisk said...
I've got two old W95 machines which I use for field work with the stamps. The revision level of the programming software is 2.2. something that I loaded last year some time.


Thanks Tom. I did load the v 2.2, and it's working. Sometimes when I hit the "run" or "identify" buttons, it fails to find the Stamp. Several retries usually succeeds. It may be something wrong in the serial connection. But...at least now, I have some portability.


Tom Fisk said...
I can confirm that W95 support of USB is pretty poor, so the serial port is the way to go.



Moot point for me. Neither of my Win 95 machines has a USP port anyway. I got the BOE with the serial cable AND the USB cable/serial-adapter, so I'm using the USB on my XP computer.

Chris Savage also sent me an email saying that v 2.2.6 MIGHT run on win 95, but that they had not tried it. In an idle moment, I might give it a try.

Bob

Chris Savage
01-16-2007, 11:14 AM
Bob,

Bear in mind that the communication problems shouldn’t change between the two versions. The only real changes to the software had nothing to do with any communication components. I see you mentioned using a laptop. Laptops are notorious for having issues related to the FIFO buffers on the serial port. Disable those and see if your problems persist. To do this go into the Device Manager and in the Ports category double-click on the entry for your COM Port (this should be the one the BASIC Stamp Editor shows you downloading to). Go to the Port Settings Tab and click Advanced. Uncheck the box, “Use FIFO Buffers” and then click Okay. Click Okay on the previous window, restart your computer and try again. I hope this helps. Take care.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Chris Savage
Parallax Tech Support

Bobalou
01-20-2007, 10:51 AM
Chris,

Apparently it wasn't the FIFO setting. I still get a somewhat intermittent communication. Sometimes it doesn't find the Stamp 2, and sometimes, either with "Run" or with "Identify" it puts vF.F in the column marked version, and tells me it can't connect with that version. I've discovered another problem with the laptop, in that four of the keys won't produce a symbol. Maybe it needs cleaning. I think I'll put the laptop on a back burner for now. Maybe until I've finsihed the WAM tutorials. Or until I really need to go portable.

Thanks for all the suggestions.

Bob