PDA

View Full Version : Anyone had a BS2px24 go bad?



RottenJalapeno
11-12-2006, 05:55 AM
I recently bought a bs2px24 and I downloaded to it just fine many times in the past, but then today I tried downloading to it and it wouldnt recognize the basic stamp in my development board.ˇ I also knoticed that the 1121a5 chip (voltage regulator?)ˇ on the basic stamp would get extrememly hot extrememly fast when I put power to it.ˇ I made sure there were no wires connected to the I/O pins, but it still got hot.ˇ Any ideas?ˇ the board visually looks fine its just that I cant see it on the development board anymore and it is getting really hot, but after I noticed the heat issue I wouldnt leave it powerd on for more than 5 secs just to seeˇif I could download to it.ˇ http://forums.parallax.com/images/smilies/jumpin.gif

I also had a bs2 laying around, that works just fine in the development board... if that helps at all

Chris Savage
11-12-2006, 06:45 AM
Hello,
ˇ
ˇˇ The regulator can be damaged due to over voltage (too much input voltage to Vin), excessive current draw from the Stamp Module and/or I/O pins or by a noisy supply or static electricity.ˇ What was connected to the Stamp Module prior to the problems?ˇ How are/were you powering it?

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Chris Savage
Parallax Tech Support

RottenJalapeno
11-12-2006, 09:59 AM
I made a prototype board that powerd the stamp through a 7805 to the vdd pin. there was nothing hooked up to the vin. that was the only thing it was hooked up to besides the professional development board. but I hooked up the bs2 to the exact same circuit, which that seemed to work just fine??? I'll try sprinkeling some pixie dust over it and possibly sacrifice it, and or some other electrical goodies as an offering to the microcontroller gods?

PJ Allen
11-12-2006, 10:08 AM
RottenJalapeno said...
"pixie dust... sacrifice... microcontroller gods"
You've nailed it.
ˇ