PDA

View Full Version : Propeller Tool v1.0



Jeff Martin
10-14-2006, 04:21 AM
Hi,

The Propeller Tool v1.0 is now available on the following page:

http://www.parallax.com/propeller/downloads.asp

Please read the included "readme.txt" file for information on what changed.


Please note that we are now hard at work on addressing more issues and adding more enhancements and will post a new version as soon as possible.· Thank you for your suggestions and feedback.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
--Jeff Martin

· Sr. Software Engineer
· Parallax, Inc.

acantostega
10-14-2006, 05:58 AM
Nice, I'm glad you solved that "no undo after saving" problem.

One of the things I'd like to see is an updated .chm help file, with a reference to Spin and Assembly instructions. Right now, if I don't remember, e.g., how "repeat" works I have to look it up in the Manual's index, see what page it's in, and go to that page. Something more like the help file in the Basic Stamp IDE with a hyperlinked basic language reference would be more convenient.

Jeff Martin
10-14-2006, 06:30 AM
Thanks.· That no-undo-after-save was an elusive problem... it was supposed to work from the first version we released, but another feature was preventing it from working.

Thanks for the request.· We are working on updating and expanding the on-line help just as you suggested and it will be included in one of the next releases of the software.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
--Jeff Martin

· Sr. Software Engineer
· Parallax, Inc.

Phillip Y.
10-15-2006, 04:31 PM
Help, I screwed up my file extensions for the .spin associations.
After installing v1.00 I did not restart my computer and when clicked on a spin file it ran the older version.
Eventually I uninstalled all the versions and reinstalled version 1.00,
the .spin was associated with windows explorer and I used right click and use OPEN With and CHOSE PROGRAM to browse for propeller.exe(v1.00) but it would not register it as my choice,
In an attempt to correct this I went to EXPLORE TOOLS· FOLDER OPTIONS· FILE TYPES and manually changed the registered type to propeller.exe,
now when I double click on a spin file it launches v1.00 but with the error message file: 'C:\DOCUMENTS.SPIN' DOES NOT EXIST .
I uninstalled and reinstalled v1.00 again but the problem continues when I double click on a spin file.

Now each tine I uninstall or reinstall any thing I always restart winows·.

Gadgetman
10-16-2006, 12:35 AM
Deinstall the Propeller tool, then open Regedit...

In the Key HKEY_Localmachine\software\classes

Search for and remove anything related to .spin

also check for and remove anything like HKEY_LocalMachine\Software\Parallax

And just to be certain, mark the top of the tree and do a search for 'propeller' to find any stray bits...

Reboot and try again...

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Don't visit my new website...

wastehl
10-16-2006, 12:43 AM
When I installed V1.0 on XP Pro it went smoothly. I then ran V.0 and it asked for permission to link the program to the file types. I did that, and had no problem. I still have both versions installed but the system defaults to the new one. If I want to go back to the V0.98 I have to use OPEN.

The Regedit fix will certainly work, but it might be prudent to set a system restore point before doing it, the registry is a tricky beast. Love the Mac...

Bill

simonl
10-17-2006, 06:44 AM
Hi Jeff,

Many thanks for the updated IDE, I've not had a chance to play with it yet, but you'll be pleased to hear that it's installed just fine on my XP SP2 laptop http://forums.parallax.com/images/smilies/smile.gif

One thing I wasn't expecting -- it installed completely separately from the v0.98.1! That means I've gotta manually copy-over all my library files :-( Maybe I missed it, but I don't recall any option to install over the previous version...

I'm also surprised that we still don't have any option to decide where the library goes -- I really dislike having my app's and work files together. I much prefer to have the IDE reside in C:\Program Files, and my work files somewhere else (e.g. D:\Propeller\Work).

Does the v1.0 IDE allow sub-folders?

Anyways, keep up the good work, add all the features we can dream-up, and in the next millisecond you'll be able to code that command-line download routine (only kidding!).

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Cheers,

Simon

Mike Green
10-17-2006, 11:01 AM
Jeff,
I run the Propeller Tool using Windows XP under a PC emulator on a Mac. In upgrading from 0.98.1 to 1.0, the Info window that shows the program tree and the hex compiler output doesn't work properly. In particular, it doesn't fit in my 800 x 600 window. When you click on Hide Hex, it just hides the buttons under the hex panes (which are still there). There's no way to make it fit in my (emulated) screen. The rest of the Tool seems to work ok although it's less tolerant of timing on the download process. I had been able to successfully download nearly every time. Now, I get an "unable to find a Propeller" message more times than not. Switching emulators from Virtual PC to Guest PC helped a little, but it's still not good enough for downloading. The COM port under Guest PC is COM3 which looks like a serial port to the PC, but is really the Demo Board's USB serial port. Under Virtual PC, the COM port was set up as COM1 or COM2, works more reliably as COM2 ... maybe the delay in trying COM1, then COM2 helped.
Mike

Phillip Y.
10-17-2006, 03:25 PM
wastehl,
Since I had previously had all propeller versions installed, I really can't say when the associations got mixed up, but once any version of the propeller was started it could open a .spin file properly, it was just clicking on a spin file to launch the propeller IDE that mixed up.
I got the associations working ok now, I deleted all references to propeller and parallax from the registry, except for a reference to a propeller font (I thought I should leave it alone).

Now v1.0 is running with something OTHER THAN the propeller font ! HELP


Here is a easy but dumb mistake I made, the red and blue leds for the USB were blinking but the propeller could not be found because it's power switch was off,
the USB is self powered (+5v) and is independent of the propeller power switch.

Beau Schwabe (Parallax)
10-17-2006, 11:56 PM
I'm not sure if this would help or not, but here is the basic setup that I have implemented on my own system that seems·functional to my requirements.



This is Windows Platform specific, although with the use of soft links in a UNIX/Linux, Mac(Os X) environment,
this solution could be made a little more elegant.

Each version is installed to a specific (default) directory:
C:\Program Files\Parallax Inc\Propeller Tool v0.95.1
C:\Program Files\Parallax Inc\Propeller Tool v0.98.0
C:\Program Files\Parallax Inc\Propeller Tool v1.0

From this point, I create a working directory that contains a Core Library Directory. The Library
Directory contains all of the common objects. Also, because I am retentive, I keep year and month
directories also. (<- That's where propeller code goes)

C:\Propeller Work\2005
C:\Propeller Work\2005\November
C:\Propeller Work\2005\December

C:\Propeller Work\2006
C:\Propeller Work\2006\January
C:\Propeller Work\2006\February
C:\Propeller Work\2006\March
C:\Propeller Work\2006\April
C:\Propeller Work\2006\May
C:\Propeller Work\2006\June
C:\Propeller Work\2006\July
C:\Propeller Work\2006\August
C:\Propeller Work\2006\September
C:\Propeller Work\2006\October

C:\Propeller Work\Library

In the Library directory I make a copies of the 'Propeller.exe' file from the install directories
and denote a specific version in the new name.

For example:

C:\Program Files\Parallax Inc\Propeller Tool v1.0\Propeller.exe

is copied to....

C:\Propeller Work\Library\Propeller-v1.0.exe

With the unique Propeller{version}.exe I make a shortcut link to the Windows Desktop. This way
any version of Propeller that I run shares a common database.


Alternatively, you could set this up with multiple Libraries so that each Library would have specific
features that others would not. You could also make use of the 'SUBST' command to assin a specific
directory to a unique drive letter. Building on this idea, you could have multiple users and setup a
script to keep work files separate between different users.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Beau Schwabe (mailto:bschwabe@parallax.com)

IC Layout Engineer
Parallax, Inc.

Post Edited (Beau Schwabe (Parallax)) : 10/17/2006 5:12:45 PM GMT

sam_sam_sam
10-18-2006, 12:39 AM
Beau Schwabe

Thanks for sharing this i just had to change my hard drive due to bad sectors on the drive and was able to copy all of my Stamp and Propeller to another
drive and install a new much larger drive in my computer and was wanting to keep the older ver. of the Propeller and install the ne ver

Sam