PDA

View Full Version : Trouble with PRC and serial programming circuit



acantostega
10-13-2006, 01:10 PM
Hi,
I got a PRC. Given the costs involved, I thought I'd try using the serial programmer circuit (as posted in the Parallax Propeller Downloads) to program the Propeller rather than the usb2ser.
Well, I built the circuit and I haven't got it to work. The Propeller tool won't detect anything ... I know the serial port and the cable are OK because I have a propstick and it works fine with them. (This is a desktop PC, not a laptop)
I'm using 2n2907's and 2n2222's instead of 2n3904/6. I'm assuming this is OK.

Just in case, what should I do with the serial port pins that aren't in use (that is, not 1,6,7,8,9)? Do I have to ground them or do I just let them floating?

Well, and just to see if the PRC was correctly assembled I pulled out the Propeller off my Propstick and connected the relevant pins (GND, reset, TX, RX) to the usb2ser pins on the PRC. And it worked! I got a blinky led program downloaded (to ram) and running. However, if I tried saving to the EEPROM, the Propeller tool would take a while, and then announce that the connection to Propeller has been lost. Why is this? I'm guessing it is because the EEPROM in the Propstick is somehow interfering, but I don't know. Any ideas?

Thanks in advance!

acantostega
10-13-2006, 02:37 PM
I've been doing some scoping, to see what's different between the Propstick and the PRC when an Identify Hardware message is sent.
There are various differences:
- the main one probably being that in pin 31 (RX) of the Propstick, I see some pulses (probably corresponding to some serial message), whereas in the PRC I see nothing (it stays high).
- In pin 30, the Propstick stays high all the time, whereas in the PRC it stays low all the time.
- The RST pin stays high in the Propstick, but in the PRC I see a burst of short (about 12us) pulses, and then it goes to high (it seems they're related to EEPROM activity).
Maybe I got the pinouts messed up? I tried switching RX and TX, but it didn't help.

Beau Schwabe (Parallax)
10-13-2006, 10:54 PM
acantostega,
I haven't tried it, but the 2n2907's and 2n2222's instead of 2n3904/6 should be fine, these are
just general purpose switching transistors.

The image located here should be the correct schematic.
http://www.parallax.com/dl/docs/prod/prop/SerialtoPropeller.pdf

This schematic was actually derived from what is currently on-board a Basic Stamp II module.
The only thing I can think of is that the PC serial port is viewed from the back of the connector
plugging into the PC, and that something got transposed there in your connection.

The unused PC serial port pinsˇshould be left unconnected.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Beau Schwabe (mailto:bschwabe@parallax.com)

IC Layout Engineer
Parallax, Inc.

acantostega
10-14-2006, 01:39 AM
Thanks, Beau. I'm suspecting I might have got the pinouts wrong. Still debugging!

acantostega
10-14-2006, 04:59 AM
Success! I had reversed the TX and RX pins, plus I had a bad joint. Once I fixed both problems it worked beatifully, including EEPROM saving.
I'm glad I didn't have to spring for the usb2ser, since I have like 4 usb-serial converters already, and getting stuff over here (Chile) ain't cheap :)

darkxceed
11-16-2006, 05:23 PM
Hello there,

Iˇuse 2 bc547 and one bc557, used the schematics on this site.

Problem now is the same as mentioned above.
P30 stays high, when pressing F7 one full pulse and some small spikes where seen on my scoop.
P31 is low, when pressing F7 some pulses areˇvisible.
The PC says 'no prop are found on com1'.

I test with and without the eeprom, don't think that the eeprom is needed when pressing F7.

What are the settings have to be?
Does some one know how to trouble shoot this problem?
How can I for example see if the prop is ok, or defect?

best regards
Bart