PDA

View Full Version : I can't see my STAMP!?



Bullwinkle
01-26-2006, 02:04 PM
Today I sat down to do some experimenting, but I could not update the compiled program. After stuffing around for a while in Linux I plugged it back into my wife's Windows laptop, where it had been working also.

But it doesn't work there either!? I deinstalled and reinstalled the software and the USB<->serial driver. When I run the BASIC Stamp Editor and select "Identify" it just sits there with COM4 displayed and an hourglass but no identification of my BS2.

My kit is a Stampworks development board. I have it connected via a USB cable.

Any ideas on what I can try? I am getting seriously worried my BS2 is dead! :-(

BTW - It is seriously hot here today (39C outside) 26C inside. Does heat effect these things?

Steve

Bullwinkle
01-26-2006, 02:06 PM
I forgot to say, the wife's laptop runs Windows XP Pro. 512MB ram, 40GB HD, no serial ports but has 2 USB ports on the back.

Steve Joblin
01-26-2006, 09:16 PM
How are you powering the Stamp? If by battery, are they fresh?

Chris Savage
01-26-2006, 10:56 PM
Hello,

·· You said when you run Identify you get an hourglass?· That sounds like the software has locked up trying to access the COM Port.· Do you have a serial connection you could try to double-check communication?· Or even another BASIC Stamp Module?

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Chris Savage
Parallax Tech Support
csavage@parallax.com (mailto:csavage@parallax.com)

Bruce Bates
01-26-2006, 11:21 PM
Steve -

Are you running HotSync or anything like that in the background on your computer? If so, shut it down, and then retry programming the Stamp.

Regards,

Bruce Bates

dandreae
01-27-2006, 03:06 AM
Hello,
·
If you click on the link listed below and open the Windows XP PDF file and then scroll down to the "Trouble Shooting" section, this should fix the communication issue.··
·
Regards,
·
Dave
·
http://www.parallax.com/detail.asp?product_id=800-00030

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Dave Andreae

Tech Support
dandreae@parallax.com (mailto:dandreae@parallax.com)
http://www.parallax.com

·

Bullwinkle
01-27-2006, 04:24 AM
Thanks for the advice guys. I have tried reducing the latency as you suggested, but nothing works. I am running off a 9vdc power adapter, so power is not a problem.

I have tried seeing in Linux can see anything coming out of the USB serial port a few times. Every now and then I see partial debug messages but it is surrounded by gibberish. I am pretty sure I have the comms parameters set correctly (9600bps 8 data 1 stop bit no parity).

It is cool this morning so it's not an overheating problem. I am starting to think my stamp may be dead, or the serial interface is fried.

Steve

Bullwinkle
01-27-2006, 06:12 AM
I thought of something while riding into work that MIGHT be relevant. On my wife's PC the STAMP "gets" COM4 allocated to the USB<->serial interface, not COM3. I'm pretty certain that it used to grab COM3 last time it was connected to this laptop. But I cannot select COM3 since it is marked as "in use" in the control panel.

Could that be, at least part of, the problem? How can I tell what is using COM3? The only other device plugged into the laptop is a mouse. It has no "real" serial ports, and only 2 USB sockets.

If all else fails I will try connecting it to one of my daughters' desktop computers. They both have real serial ports, so I can isolate whether the problem is with the STAMP or the USB<->serial software.

Why Linux should simultaneously have a problem talking to the STAMP is another mystery. But I will get it "talking" to Windows first, then adventure back into less charted territory.

Assuming I can get it working at all... http://forums.parallax.com/images/smilies/confused.gif http://forums.parallax.com/images/smilies/sad.gif

Bullwinkle
01-28-2006, 11:43 AM
BUMP http://forums.parallax.com/images/smilies/smhair.gif

Bullwinkle
01-28-2006, 12:38 PM
I have made some progress on this problem.

I deinstalled the USB<->serial driver, noted that COM4 ( and strangly COM3 also ) had vanished. Reboot.

Plug in USB cable to Stampworks, "Found new hardware" - directed it to the Parallax USB driver. So far so good.

BUT THEN IT GETS WIERD!

The "Found new hardware" wizard pops up again, It is not happy with my selection of the Parallax USB driver. If I let it select a driver automatically it installs a Microsoft Serial Mouse driver, which immediately grabs COM3!

So, went into SYSTEM control panel, device manager, found the Microsft Serial Mouse - uninstall!

As a test I fired up hyperterminal, COM3 9600bps 8 data 1 stop no parity, and BINGO - they are my DEBUG messages displayed perfectly. Hooray!!!! :)

At least I know my BS2 is working OK!

HOWEVER, I *still* cannot get the Stamp Editor to identify (CTRL-I) the stamp. I just get an hourglass that does not go away!

I've gotta be close. WTF is going on????

Also, whenever I unplug and plug the USB cable - the damned Microsoft Serial Mouse drivers pops up again and grabs COM3!

Jon Williams
01-28-2006, 12:45 PM
I believe you're supposed to install the FTDI driver BEFORE you plug in the device.· And, weirdly, under XP it will act like it wants to reinstall again·and you have to go through those steps (see the document below).· After following the steps in our documentation I've used all of our USB products under XP with no issue.·

http://www.parallax.com/dl/docs/prod/ftdi/USB-VCP-Install-WinXP-v1.1.pdf

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Jon Williams
Applications Engineer, Parallax

Bullwinkle
01-28-2006, 12:54 PM
How can you install the driver driver BEFORE plugging the device in?

The documentation says to copy the driver to your harddrive then plus in the USB cable, then talk to the "Found New Hardware" wizard, but tell it you have the driver in this directory here.

I've done all that - still the Stamp editor is upset. Is there a registry setting that is perhaps up the spout?

I made another discovery regarding the Microsft Serial Mouse too. If my STAMP is off when I plug it into the laptop, it doesn't think it's a mouse. Wierd...

Bullwinkle
01-28-2006, 01:06 PM
IT'S WORKING AGAIN!!!!! http://forums.parallax.com/images/smilies/yeah.gif http://forums.parallax.com/images/smilies/yeah.gif http://forums.parallax.com/images/smilies/yeah.gif http://forums.parallax.com/images/smilies/turn.gif http://forums.parallax.com/images/smilies/turn.gif http://forums.parallax.com/images/smilies/turn.gif http://forums.parallax.com/images/smilies/tongue.gif http://forums.parallax.com/images/smilies/tongue.gif http://forums.parallax.com/images/smilies/tongue.gif

The solution was to nuke the register entries for Parallax and below in the HKEY_CURRENT_USER bit of the registry. I must have somehow been buggered.

Thanks for all you help guys

Bullwinkle
01-28-2006, 02:18 PM
Now that I have it going again under Windows, I was confident enough to tackle the Linux comms issues. It turns out my stty settings had gone west similar to how the registry had gone west on my wife's computer. 2 similtaneous software problems - on separate computers. What are the odds? No wonder I thought it was a hardware fault with the STAMP!? http://forums.parallax.com/images/smilies/confused.gif

Anyway the stty settings that enable a Linux computer to talk to a BS2 ( via a USB<->serial port) are:

/bin/stty -F /dev/ttyUSB0 ospeed 9600 ispeed 9600 ignbrk -brkint -icrnl -imaxbel -opost -onlcr -isig -icanon -iexten -echo -echoe -echok -echoctl -echoke

Maybe this will help another brave Linux-STAMP user out some time. http://forums.parallax.com/images/smilies/tongue.gif

Now, where was I ? ... http://forums.parallax.com/images/smilies/turn.gif