PDA

View Full Version : Hardware Comm Failure



TomS
01-25-2006, 08:09 PM
I'm having problems downloading my program. I keep getting a "Hardware communications failure" error message. I have tried 3 different RS-232 cables, 4 power supplies, a BS2P24/40 Demo Board and a homebrew board & a BS2P24 and a BS2P40. What's funny is that it sometimes works. Actually it has worked for two weeks before the first failure. When I try to Identify the chip after a failure I get a "No" for the echo. I believe its starting to look like my computer.

Any ideas?

Tom

deno
01-25-2006, 09:11 PM
I had this problem off and on and I would drive me crazy. I discovered that my laptop ground (the metal part of the DB9 pin connector in the serial COM port was not grounded to the ground of the Basic Stamp project. I know there is a ground in the cable, however, as soon as I ran a seperate wire with clips on both ends to connect the grounds, the download problem went away.

As I said, sometimes I wouldn't have to resort to this additional grounding, and other times I would have to.

Most of the time I am using a 12 volt car battery under my work bench as a pure DC power supply. I am guessing that there is/was a bad connection on the DB9 connector (which end I don't know) between the computer and the project ground.

Hope this helps
Deno

Bruce Bates
01-25-2006, 09:16 PM
Tom -

It sounds like there may be a loose connection somewhere if it works some of the time, and not others. I'd stick with the BS2P24/40 Demo Board, one of the straight through RS-232 cables that you trust or that you've checked out, and the most stable of the power supplies.

Continually changing the various components necessary for programming, as you've been doing, is a shotgun approach which will only drive you crazy in the end. Use the most trustworthy components you have, and then try to shoot the problem from there.

Are these RS-232 cables particularly long?

Have you tried more than one computer?

Is this a desktop computer, or a laptop?

Which operating system are you using?

Is the program exceptionally large?

If you haven't tried another computer, look carefully at the one you're using. You might want to make sure the serial port is solid, there are no bent pins, and if it's on a separate I/O card that the card is firmly seated in the I/O slot inside the computer.

If possible try to download the program using a different computer.

Regards,

Bruce Bates

TomS
01-26-2006, 02:22 AM
Thanks for the info. I switched everything over to my old laptop (a three hour process) and the download worked fine. I measured continuity from the AC adapter ground pin to the connector shell on both laptops and it was less than an ohm so I still don't have a positive indication of whats wrong. I'll try running a ground wire between the computer and the board. This problem seems to have a common thread, ie, laptops. I guess those big old hunks of metal that others put under their desks must have a better ground than laptops.

Thanks
Tom

TomS
01-26-2006, 05:17 AM
I've tried external grounding. It still won't download. I think there is something wrong with my laptop. The next step is to put a scope on the RS-232 connector and see if anything is being sent in either direction.

Tom

allanlane5
01-26-2006, 05:56 AM
You might try disabling (or setting to zero) any "FIFO" settings in the laptop's serial port. My Toshiba always had a problem with that.

TomS
01-26-2006, 06:47 AM
Disabling the serial port FIFO buffer didn't make any difference. Isn't there a way to check serial ports with a loopback connector?

Tom

Chris Savage
01-26-2006, 07:14 AM
Tom,

You can find examples of testing your serial port using a home-brew loop back connector by searching Google.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Chris Savage
Parallax Tech Support
csavage@parallax.com (mailto:csavage@parallax.com)

PJ Allen
01-26-2006, 09:33 AM
Darned handy -- http://www.bb-elec.com/product.asp?sku=9pmtt

$40, no guessing, worth every penny.

TomS
02-03-2006, 10:33 AM
Finally! I made up a loopback connector and observed the waveforms on an oscilloscope. The voltage levels were sometimes dropping into the undefined zone of the RS-232 spec. Next I had to convince Dell tech support that the problem was not my fault. This took 5 hours altogether on the telephone speaking with someone who could barely speak English. They sent a tech out today with a new mother board. Now all is back to normal. I'm not sure the LED adapter would have found the problem unless it accurately responds to the voltage levels. The computer itself passed all self tests.

Thanks Everybody
Tom Smuts