PDA

View Full Version : sid64



troxxan
04-05-2012, 02:27 AM
i tryed sidddump 1 time and worked next time i get this ..
windoves is a funny thing,
[ATTACH=CONFIG]91364[/ATTACH

Circuitsoft
04-05-2012, 07:00 AM
Be sure you actually extract the files somewhere; don't just run it from the zip file.

troxxan
04-05-2012, 11:54 AM
its not a compacted file.

average joe
04-05-2012, 02:07 PM
I just tried the program myself, and something's wrong. I changed the audio out pins and uploaded SIDcogSlave to my HW, started the player and set COM and baudrate, and nothing? Any suggestions how to figure out why it's not working? SidCog tested good on HW.
My PC is Win7 Enterprise, player runs, but no output from sid. Internal sid emulation works.. Any help would be greatly appreciated!

Ahle2
04-05-2012, 03:01 PM
@troxxan
Looking at the picture you have attached it seems like you are running the exe-file by clicking on the file directly from within the zip-archive. You have to extract all the files to a folder and then run the exe-file.

@average joe
1. Run the propeller tool.
2. Press F7 and write down wich port that your Propeller is connected to.
3. Upload the SIDcog slave to the eprom of your Propeller board.
4. Exit Propeller Tool to "free the port". (IMPORTANT)
5. Reset your board.
6. Start SIDcog serial player and enter..
COM port: COMx
Baud rate:115200

7. Start playing music, It should work!

/Johannes

average joe
04-05-2012, 03:30 PM
Well I gave it a couple more tries, but no luck. Followed your procedure exactly. Not sure what the problem is, and I have more important fish to fry right now. Just thought it would be nice for testing.

Ahle2
04-05-2012, 03:49 PM
You are compiling "SIDcogSlave.spin" and not "SIDcog.spin" right....or !? :tongue:
I just tried it on my Quick Start board and it works flawlessly.

Have you got any indication when data are recieved on your board?
It should be a constant light when everything is okey and music is playing.

Note that the name of the port must be the whole name without any space. "COMx" is valid "COM x" or "x" is invalid.

average joe
04-05-2012, 09:40 PM
Yes, I was compiling SidCogslave.spin
There is no real reason I can see it doesn't work. I will be reviving other HW and be testing with a propPlug as opposed to 2323. I've been having problems with programming anyway, so guessing this is related. Thanks anyway!
Could you please look at the sid thread and give me a quick reply? I think I'm close but it would help for you to verify my postulation. Thanks again for your time, I hope trox has this working!

troxxan
04-23-2012, 08:23 AM
i have it up and running, only problem are i can only run that .exe file once then i need to restart computer :O