PDA

View Full Version : Prop BOE can't find any ports



dmagnus
03-24-2012, 01:06 AM
I just got my Prop BOE today. Installed the Prop Tool (it's version 1.2.6 - I already had 1.3 installed but uninstalled everything before I installed it). When I plug it in to the USB port on my laptop (Dell XPS with Windows 7) and try to "identify hardware" it displays an error "no serial ports found".
I had a Gadget Gangster prop board hooked up to this computer (must be where v 1.3 came from) and it worked fine...
Any ideas?
Don

xanadu
03-24-2012, 01:28 AM
Can you see the serial port in device manager?

Is the BOE powered up/tested?

Phil Pilgrim (PhiPi)
03-24-2012, 01:31 AM
I'm curious why you downgraded from 1.3 to 1.2.6. Perhaps the FTDI driver got uninstalled in the process?

-Phil

dmagnus
03-24-2012, 02:16 AM
I can see a bunch of USB ports in Device Manager. In Uninstall Programs I have FTDI and Parallax CDM drivers listed.

dmagnus
03-24-2012, 02:17 AM
The Propeller Tool 1.2.6 is the one that downloads from the Prop BOE instructions, so I uninstalled the 1.3 version and installed the one that "came with" the BOE.

dmagnus
03-24-2012, 02:19 AM
When I plug the USB cable in, the tx and rx lights on the BOE both flash once. And the BOE has a green light with the switch in position one and two green lights in position two. I don't know how to test it any further without being able to "talk" to it...

Martin_H
03-24-2012, 02:34 AM
Going back a version with Windows programs can result in problems because the newer version might leave a shared DLL that the older version isn't compatible with. I would try the software version you had on the system that worked previously.

This is so common it has earned the moniker DLL Hell and I've been there many times since 1993.

Phil Pilgrim (PhiPi)
03-24-2012, 03:11 AM
I agree with Martin. Dump 1.2.6 and go back to 1.3. There's no reason to use an older version.

-Phil

dmagnus
03-24-2012, 02:11 PM
MY BAD!! It turns out I was using the wrong usb cable. I've got so many of them laying around, I was using the one that came with the speaker instead of a "real" one. Everything fine now. AndTnak, I have all of the latest drivers, etc.
Thanks

John Abshier
03-24-2012, 03:22 PM
That is why my speaker usb cable is in the trash.

John Abshier

Phil Pilgrim (PhiPi)
03-24-2012, 04:15 PM
Oh crap! I had no idea the speaker USB cables were different. Now I've got a rogue cable loose on my benchtop, and I don't know which one it is. I guess I'll find out the hard way and -- hopefully -- remember this thread before I waste an entire day chasing a phantom problem.

-Phil

dmagnus
03-24-2012, 10:27 PM
Yup, I think the speaker usb cable is power only. Just to charge the battery.