PDA

View Full Version : Unsolved Servos won't work



Zorro
03-04-2012, 05:43 PM
This is my first attempt at Robotics. Bought the Boe-Bot kit and began learning/building my first Boe-Bot. I cannot get the servos to work as per the manual/lesson plans. I have checked all pin settings on my Board of Education/breadboard as well as moved the Vdd/Vin settings to Vin. Plugged my servos in X5 - 13 & 12. Using usb, switch on, 6V power supply, with switch in position # 2 (battery voltage correct) entered correct programing commands (which all previous program commands worked prior to starting to deal with servos.) for centering servos on P12 and then tried P13. Neither servo worked. Tried Activity #6 which is testing the servos, again neither worked. I can't believe I'd have two bad servos in the same kit. Any suggestions?

Martin_H
03-04-2012, 05:58 PM
A possible gotcha is that you might have the servo plugs in the wrong orientation. Make sure the black cable is on the ground pin. Another is that the batteries might not have enough power and when the BS2 commands the servos to move it bowns out. That causes the program to restart from the beginning ad infinitum.

Also make sure you have the jumper installed between the servo jack pairs. Without that the power pin won't have power.

Zorro
03-04-2012, 07:55 PM
Martin,
thanks for the tips, checked them all, confirmed correct settings, locations, pins etc. Still not working.

Duane Degn
03-04-2012, 08:00 PM
As Martin mentioned, your battery supply needs to have enogh power for the servos and BS2. What kind (how many etc) of batteries are you using?

Do you have a multimeter to measure voltages?

Do you have any sort of radio control equipment so you could test your servos in a different system?

Zorro
03-05-2012, 12:11 AM
I have new batteries reading about 6.03 V. Don't have anything elese to test them on.

Duane Degn
03-05-2012, 12:21 AM
I have new batteries reading about 6.03 V. Don't have anything elese to test them on.

It would also be good to know the size and chemistry of the batteries. AAA even if new, could be a problem.

I pesonally like AA NiMH batteries for a lot of my robot projects.

How about, without the servos connected, making a loop that sets pins 12 and 13 high for a second and then low for a second and checking with the volt meter to be sure the header pins are getting the signal from the BS2?

erco
03-05-2012, 01:53 AM
Remove servo connectors from BoE. Use 3 jumper wires directly in servo connector to P12, ground, and Vin connections and test.

GordonMcComb
03-05-2012, 05:19 AM
Try disconnecting the USB cable after uploading the program. Press the BOE reset button to re-run.

Add the piezo speaker as shown in the activities a little later on. This will help you know the program is re-running, and not started over and over again because of brownout (which sounds unlikely).

Are you saying the program for calibrating the servos also didn't work? In what way did it not work? Turning the side adjustment on the servos had to effect?

-- Gordon