PDA

View Full Version : Unsolved BS2P to SLED-C4 Serial LED Display issues



tahlorn
11-11-2011, 09:16 PM
... Solved it. Seemed one of the posts similar to this I got after posting this had the solution. Was a BS2P issue, 19.200 baud is set as the constant 110, NOT 32. Well then, problem solved! Mod, please feel free to delete.


---------


Greetings all!

I have just acquired the SLED-C4 module, and am having some issues with it. I see that this is used by a lot of folks here, so figured you all might be able to help me out some.

I am trying to run the sample program from the Rentron site. However, all I have displaying is 8888 at high brightness. Baud is grounded so is at 19200, +5V is supplied from an external source (with a common ground), signal is to P0 and AUX line is to P1.

I run the program, and with an oscilloscope attached to the data pin I can see that it is indeed getting communication. Main state is at +5V with very fast pulses to 0V for what I am assuming is the signal.

Solder connection to the 5 pins are good.

Is there any code I could run as an error-check or evaluation? Signal is coming in as I would expect, and I can send Hi/Low signals to the output pins without any issue.

Rather new to all of this. Thank you all in advance for any help!

-Michael

PS: In checking for good connection or shorts, I found that I have a 10-Ohm resistance between Ground and P0. Not certain if that is expected or not.