PDA

View Full Version : Problems recognizing propeller boards



cfox
11-09-2011, 12:23 AM
Hi everyone. I've recently bought a couple of new propeller boards (a quickstart and a pro dev board) and in both cases, the board is not recognized by the propeller tool. I've tried this both with BST and the official propeller tool, on mac, linux and windows. (BST on mac and linux). The boards simply are not recognized.

Has anyone else had this problem? My older boards work fine on all these platforms with both programs, and so do a couple of home made boards.

Mike Green
11-09-2011, 12:34 AM
Check your USB cable. There's no particular problem with the QuickStart board and the Professional Development Board has been around for quite a while with no problems in this regard. Both the Propeller Tool and BST work fine. That doesn't leave much.

The Propeller has to be powered to be recognized. In the case of the QuickStart board, power usually comes from the USB port. The Propeller also has to have a working serial connection to a PC. The Propeller Tool installer also installs the proper USB driver for Windows. BST does not. Make sure you download and install the proper FTDI driver for the MacOS. Linux already comes with an FTDI driver.

If you were having a problem with just one of your new boards, I could believe that you got a defective board. It's rare, but it can happen. Two boards ... I don't know. That doesn't make sense.

cfox
12-31-2011, 05:14 AM
It turns out, the problem was an older ftdi driver on my computer. The older driver worked with my original propeller boards, but I guess ftdi updated their chips and so the new boards didn't work.

It was the "kind of working, kind of not" that threw me off.