PDA

View Full Version : Solved trouble pointing at resources...



tommy
10-28-2011, 02:57 AM
hello. I downloaded propeller files in the spring of 2010 (v1.2.7)
then my house flooded, and I moved...
I'm beginning again, and have download (more up-to-date) propeller files again...(v1.3)

I put "fsrw.spin" in the Library file under v1.3 - the newer one.

but the compiler can't find "fsrw.spin"
--- while pointing me to
----- a "work file" in the newer Propeller Tool v1.3 and
----- a "library file" under the older Propeller Tool V1.2.7 --

--- I'd like to just erase (delete) the older version of Propeller Tool 1.2.7,
----- but won't the new Propeller Tool v1.3 still be looking for the Library directory in the old location ???

how do I change those pointers ???

tommy

Clive Wakeham
10-28-2011, 03:56 AM
Well my library path is in the registry under;

C:\Program File(x86)\Parallax Inc\Propeller Tool v1.3\Library\

tommy
10-28-2011, 06:59 PM
yes. I downloaded twice and I have two Library Directories under Parallax Inc:
--- from march, 2010 --- C:/Program Files/Parallax Inc/Propeller Tool v1.2.7/Library
and
--- from september, 2011 --- C:/Program Files/Parallax Inc/Propeller Tool v1.3/Library

I don't remember setting up any pointers to the library directory (PC laptop - Windows Vista)
--- and no one else has responded in 18 hours.

I'll rename the older version of Propeller Tool, so it won't be found - and see if I'm prompted to point to a Library directory or if the remaining Propeller Tool Program will search for itself.

Phil Pilgrim (PhiPi)
10-28-2011, 07:58 PM
Try uninstalling both versions and reinstalling the newer one.

-Phil

tommy
10-28-2011, 08:34 PM
thanks, Phil -- the "rename" worked. no programs asked me any questions - the particular file in question, "fsrw.spin" was succesfully found in the only place it exists - in the new directory. if no further trouble, I will simply delete the old directory in a few days.

Yes (!) - I want this tiny little gizmo on my table-top ($80) to be more powerful than my Radio-Shack TRS-80 Model-1 ($4800) was, back in 1980 - so I will gladly suffer through these tutorials to be able to learn to use the SD-card... (I can't believe how small it is) !
--- but I can't wait to get back into Assembly-Language-Only for my (right now) Solar Hot-Air Controls. This Spin-language stuff brings with it (to me) a giant fog - After just now successfully running the tutorial named, "Mount.spin" - the screen on the "Propeller Serial Terminal" reads, "SD-card successfully found and mounted" --- and I have no idea at AT ALL what has just occurred ! - except perhaps I did indeed follow the formatting instructions properly. (what does, "mounted" mean ???).

Assembly Language definition:
a boyscout on the beach picks up a rock, looks on the bottom, and does the simple operation written there.
and then he picks up the next rock...
repeat
repeat
repeat
amen.