PDA

View Full Version : Having a hard time sending the propeller commands serially



turbosupra
10-26-2011, 04:39 PM
Here is my code

http://turbosupra.herobo.com/hosting/10-26-11.zip

I'm trying to tell the propeller how many times to flash pin 23 (LED) before a 2 second pause. Through the parallax serial terminal, I am sending the code "flashes=4" and you'll see in the parallax serial terminal that something goes awry with the variables value after it updates.

I believe I may have a problem with my variable "flashes" which is a long, and < (less than) might not work well with longs, but I'm really not sure.

Any direction on this would be very much appreciated, I've been working on this for about 2 months and am close, but cannot seem to get past this issue. I'll keep plugging away but would like some direction. Thanks for reading.

StefanL38
10-26-2011, 05:02 PM
Hi Brad,

I tried to unzip the archive but I only get an error-message zip-file damaged.

I'm trying to help without seeing the code anyway. If you receive the character-sequence "flashes=4" this has to be stored into a bytearray. (= which acts as a string-"container")

Of course you can put an external link into a posting. You can attach zip-files to a posting too.

keep the questions coming
best regards
Stefan

Duane Degn
10-26-2011, 05:22 PM
I also couldn't unzip the file. I'm having internet trouble so I wasn't sure if the original file was bad or not.

Duane

turbosupra
10-26-2011, 05:36 PM
It's me I think, the work firewall makes it so that I cannot upload attachments directly to the forum, so I'm trying the direct link to a host instead. I'm sorry about that everyone.

Stefan, I will email it to you and try to work on the byte array after that.

turbosupra
10-26-2011, 05:54 PM
Is there a way (api) to email the forums and have a file hosted/uploaded?