PDA

View Full Version : Burnout Trouble Shooting



Kirk Fraser
10-12-2011, 05:31 AM
I apparently switched the wires on a 28VDC 10A power supply as I was hooking it to a solderless prototype board with a complete Propeller layout plus a few other chips. A spark shut down my whole computer. After removing the power supply restarting I was unable to detect any function on the board except the PropPlug light came on when restarting.

Normal communication between the serial terminal and propeller did not return. I reloaded the Propeller Tool and checked hardware which said, No Propeller chip found on any serial port. Scanned: COM1, Scanned COM2. However it had previously used COM3.

How do I tell if the PropPlug is ok? If I just burned out a Propeller chip, is there a way to tell other than simply replacing it or is that the best action? And what about the other chips like memory, etc.?

In the past I've had trouble with grounding my computer. It's solved for my PC works but it may not be grounded correctly or my power supply may be grounded in error. How can I tell if that was the trouble?

My separate Propeller power supply continues to deliver 5v and 3.3v. What is the recommended trouble shooting process? I would prefer not to spend a lot by throwing money at chips and a new PropPlug if I can avoid it. Thanks.

ElectricAye
10-12-2011, 05:45 AM
Kirk,

Do you happen to have a schematic of the layout that you can show to the forum? Knowing what's connected to what will help people provide suggestions on how best to go about troubleshooting this.
Even a photo of the board might help get people thinking.

Kirk Fraser
10-12-2011, 06:00 AM
Thanks for the suggestion. I need to finish making a PCB anyway so maybe I posted too soon. I'll just try the PCB when it's ready and return to this thread if there's still problems. Posting a picture will be easier to follow with less spaghetti wiring. But the basic circuit is very similar to the published Propeller wiring schematic and the wires on the programmable pins can be disconnected and ignored for this basic short problem, since it was all working before.

Ok, I snuck in a possible repair by replacing the Prop chip and seeing if the software could detect it. It failed. So that tells me I probably need a new Prop Plug between the computer and chip set.

Toby Seckshund
10-12-2011, 07:15 AM
I put a 9 Volts PSU straight onto a Prop board (Clusso Blade2 copy) by mistake, I now have a big tape notice on it !

Fortunately I had the SRAM off board at the time but the Prop, EEPROM and 74HC373 were toast. The SD card worked again, after it had cooled down enough to catch hold of! 28 Volts would have done for the lot I am sure.

Many decades ago I worked at a place that had a load of chunky PSUs that had dual ranges selectable by the tiniest switch on the front panel. It would give 0-15 V or 0-60 V with a dual dial on the front meter (which also switched over to do the current) , loads of stuff got it from that little baby. I modified some of them to have a red bulb lit on the high range (LEDs were exotic then).

4x5n
10-12-2011, 04:00 PM
I like to put a bridge rectifier at the power input of my proto boards. It means upping the input voltage by ~1.2 volts to account for the drop across the two diodes but that's not normally a problem. I see it as a form of cheap insurance. I started that back in high school when I reversed the polarity on a project with a bunch of TTL chips. It took me two weeks to save up enough money to replace the chips I blew in that half second!

Duane Degn
10-12-2011, 06:44 PM
I've managed to ruin two Prop Plugs and the USB connection on one of my USB Propeller Protoboards.

If you buy Protoboards five at a time, the USB version costs $5 more than the normal Propeller Protoboard. With a Dremel, some solder and time, you can turn the extra $5 into a $15 Prop Plug.

To do this, I cut the USB part out of a USB Prop Protoboard and attach a right angle female header. The Vss pin needs to be connected to ground. The ground plan next to the Vss pin is not connected to ground (the cut isolated it).

http://forums.parallax.com/attachment.php?attachmentid=85898&d=1318440575

Just and idea for those who are as hard on their Prop Plugs as I am.

Duane

Loopy Byteloose
10-12-2011, 07:00 PM
Well, if you want to salvage bits and pieces, you might try these things.

1. First, try to loopback the Prop Plug and use the serial terminal emulation software in your OS to confirm that it is functioning properly. (You just type from the keyboard and it should show up on your screen). That is simply a matter of jumping the RX to TX.

I know the 3rd item to test is the reset and needs to be considered. Some terminal programs allow you to set it permanently on or off via a toggle feature. In that state you could test it with an LED to indicate it is working.

2. First of all, verify that you have a good 3.3 volt supply. Everything is pointless if the regulators have gone rogue.

The Propeller will load directly to RAM without the use of the EEPROM. If it loads and you can verify all the I/O are functions (try a block of 8 LEDs to test 8 lines at a time with a blink routine), then you should be good to go. When there are serious doubts about the EEPROM, you might even do this with the EEPROM removed.

3. Having gotten the other two working, just load to EEPROM and see if it will boot from a reset. You may even load a pattern to the whole EEPROM to verify that no damaged segments exist.

That's the gist of it, but you will have to discover your own hardware and software kit to do these things. I have an old terminal program that will allow me to do Item #1 quite easily. Item #2 is not very hard to do and I set up an 8 LED bar to test BasicStamp i/o a long time ago. I can use the same with the Propeller. Item #3 would take a bit more development on my part, but I am sure someone here can find a way to use Propeller Assembly to run a self-test and diagnostic of both the Propeller RAM and the EEPROM.