PDA

View Full Version : No Propeller Chip Found on any Serial Port ... Problem



RamC
11-25-2010, 04:55 PM
Hello,

I would like to request for some help.
I have an academic project due by Monday, November 29.
I hope some kind soul will be able to help me during this Thanksgiving weekend.

I am working with Parallax Propeller Education Kit 40 PIN DIP Version (I am going through PEKITLabs-v1.2.pdf for rmy setup).
I have completed the "Socket the Propeller Chip and EEPROM" step (Pages 30 and 31) successfully.

I am on the "Connect the Propeller Plug to the PC and PE Platform" step.
On this step, I see that Propeller Plug's Serial Transmit and Receive LEDs do flicker briefly (with battery still disconnected).
But, I see that the LED (I tried with Red and Green) that is plugged into (RED, 10) and (L, 10) DOES NOT glow faintly (according to instructions, it should glow faintly).

However, on the next step "Connect the Battery Supply", I see that the PowerLED: (RED, 10) and (L, 10) glows brightly as per instructions (although it did not glow faintly on the previous step) when I connect the battery. My NEXT problem is, when I run "Identity Hardware" from Propeller Tool, I see a message box "Communication Error" with a message "No Propeller chip found on any serial port. Checking COM3.

I verified all the voltages on the board (as per troubleshooting instructions), reseated the Propelelr and EEPROM chips, tried different USB ports on my computer, and also with a different USB cable.

Yesterday, when I tried for the first time, everything worked perfectly (Propeller Chip Version 1 Found on COM3) and I was on to testing all my I/O pins (I was able to load programs into EEPROM, use the Reset button successfully etc.). During my testing of the I/O Pins, I found that my P0 was bent a little bit, so I took out the Propeller Chip, corrected the bent, and reseated, and since then I have been getting this error and never was able to get out of it.

I am completely lost on what I can/ need to do.

Thanks and Regards,
Ram