PDA

View Full Version : Please Help!



Connor149
11-18-2010, 04:52 PM
My propeller robot controll board is not working. i was testing programs, and it was working fine, then i tried to load program one time and it just didnt work and hasn't since. I have tried 2 sets of batteries besides the origional ones, and a wall pack to check if the power was problem. what i dont understand is that when i connect the USB, the lights flash like it connects, but the program can not find the board.

any solutions, suggestions or similar problems please post! i need this board for a project and cant afford much down time.

Mike Green
11-18-2010, 04:59 PM
You may have installed the Windows I/O driver wrong. Uninstall the FTDI USB to serial adapter driver and make sure you're not using the Windows default driver by mistake, then download a new version of the driver and install it. Make sure the robot control board isn't plugged into the PC when you're installing the driver.

See instructions here (http://www.parallax.com/tabid/530/Default.aspx) and the troubleshooting link at the bottom of the page.

If that doesn't do it, give Parallax Tech Support a call.

Connor149
11-18-2010, 05:31 PM
i went to the link and site you suggested, but none of that solved the problem. i already called tech support nd they said the only thing they can do is have me send board in, and they can test it. i dont have time to spare for that. the thing about it is, it was working perfectly fine, then randomly the computer stopped being able to detect it.

David Betz
11-18-2010, 05:38 PM
I had a similar problem with my Hydra board a while back. It would work fine and then suddenly the PC couldn't find the Propeller chip anymore. I tried rebooting the PC and power cycling the Hydra and nothing made it work again. However, it would sometimes magically come back to life it I didn't use the Hydra for a while and came back to it after it had been idle. I eventually got tired of this behavior and swapped in a new Propeller chip and I haven't seen the problem since. The odd thing is, I recently bought a Propeller Professional Development Board which doesn't come with the Propeller itself. I plugged in my old Hydra chip and the PPDB seemed to work fine with it. Maybe there was a flaky connection and plugging and replugging the Propeller chip on the Hydra is what fixed it not just the new chip.

So, you might try swapping in another Propeller chip if you're using the PDIP version and have a spare chip or maybe just reseat the existing chip.

Edit: hmmm... I see that the RCB uses a QFP version of the Propeller so I guess my suggestion doesn't apply. Sorry!

Connor149
11-18-2010, 05:48 PM
unfortunately, my chip is soldered right onto the board, and the chips can not be interchanged.

David Betz
11-18-2010, 05:51 PM
unfortunately, my chip is soldered right onto the board, and the chips can not be interchanged.
Yeah, I looked up the RCB right after I posted my message and noticed that it uses the QFP version of the Propeller. Sorry!

David Betz
11-18-2010, 06:08 PM
Okay, I have another probably desperate experiment you might try doing. I was never completely convinced that there was anything wrong with my Propeller chip when I had trouble with my Hydra. It seemed more like Windows USB support was having a hard time sorting out its devices. Is there any chance you could install the Propeller Tool on some other PC and try connecting from that PC? That would eliminate USB/FTDI configuration issues.

potatohead
11-18-2010, 06:15 PM
You could also try a different cable. I've had trouble with either longer ones, or those with very thin, small wires.

Connor149
11-18-2010, 06:53 PM
i tried another cable, reinstalling drivers, and using 2 different programs to try and find the controler, of course none of them worked

David Betz
11-18-2010, 07:02 PM
Have you tried unplugging everything from the board except the power supply and USB cable? Is it possible that some of your other circuitry is causing a problem for the RCB?

Sapieha
11-18-2010, 08:49 PM
Hi Connor149.

Some times it help with change USB port it is connected to.



i tried another cable, reinstalling drivers, and using 2 different programs to try and find the controler, of course none of them worked

max72
11-19-2010, 01:36 PM
test the board on another PC, or on the same PC with a linux live distro and BST.
This way you can exclude a windows registry issue.
Massimo

Connor149
11-22-2010, 03:51 PM
i have tried different computers, an i have ran it without anything extra connected

kwinn
11-22-2010, 04:19 PM
Have you checked to make sure the com port assigned to the USB adapter is the same as the com port specified in the propeller tool?

wires
11-22-2010, 04:33 PM
i had the same problem, being new to microcontrollers i was not sure what was going on, worked away fine for a while and then just stopped. i didnt even have anything else plugged into it (just learning to flash the on board leds) i sent it back and got a new replacement. everything has worked perfect since then. still not much good at coding though :cry:

Connor149
11-22-2010, 04:45 PM
well, that is just what i am planning on doing. it must just be the board, i think

BigFoot
11-22-2010, 04:48 PM
I have had allot of trouble with the cables also, especially the ones that have
the cable retract reel.