PDA

View Full Version : Can't get my BS2 detected.



Frenchtoast
04-17-2010, 06:44 AM
I've borrowed a Board of Education, BS2, and Boe-bot kit from my Electronics teacher. I'm highly interested in building this bot, but I can't get my BS2 to popup in the editor. I've tried new drivers, reinstalling the software, changing the batteries on my BOE, etc.

I use the Parallax USBto232 USB/Serial adapter into my Vista system, with the latest version of the editor installed.

When I go to Run>Identify, my USB/Serial port is listed as COM4. The Device name thing is blank, and the loopback and echo boxes say yes.

How can I get this to work?

logan996
04-17-2010, 08:28 AM
i've got the same problem! this has hapend to me on my BS2 homework board! when i try to load programs on it it will shut off untill the pc is done searching for it! I have a project involving this on tuesday so i need help too, this happens every once in a while with no warning and i usually have to wait a couple days before it works again, why does this happen? it's happend about 4 or 5 times in the past 1 or 2 and it always works again in a couple days, any help?

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
"When the government is afraid of the people there is liberty, when the people are afraid of the government, there is tryanny"

Thomas Jefferson

Franklin
04-17-2010, 09:07 AM
Is the stamp in the right way and is it powered up? Are you sure the usb serial port is 4? Go to device manager and see what port appears and disappears as you plug in and out the usb cable.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
- Stephen

erco
04-17-2010, 09:47 AM
BRAND NEW (not just different) 9V batteries solve 90% of these newcomer problems.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
"If you build it, they will come."

Electrolord
04-17-2010, 10:15 AM
i ran into a simaler problem when i pulled my bs2 out of the box. turned out i didnt install the drivers. haha, do you have the latest version of software from parallax?

logan996
04-17-2010, 10:24 AM
yeah i got everything, even licked the 9v :D it works :)

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
"When the government is afraid of the people there is liberty, when the people are afraid of the government, there is tryanny"

Thomas Jefferson

Mike Green
04-17-2010, 10:32 AM
You can always download the latest software from Parallax by going to their main webpage and clicking on the Downloads button. For the Stamp software, use the "Stamp Software" link. If all you need is USB drivers, you can also go to FTDI's website and download the VCP drivers for their chips from there.

This question comes up over and over again and 95+% of the time it's either a power problem (like a dead battery) or a problem with the serial port, something as simple as a faulty USB cable or a missing or improperly installed USB driver. Remember that Windows will use its default driver (which doesn't work for downloading) if you connect the USB device before installing the proper driver.

Some external USB to serial adapters don't work properly (for downloading).

Sandhuamarinder
04-17-2010, 02:43 PM
Did u assembled the stamp
Simple problem man u had fried it up man. Which i did man so buy new one.

That could be the problem. Second. Your adapter is not good some of the power is passing by it and not full which happened with me.

Or You play with ports if u are getting edit pots some. If still doesnt work then goto control panel. And play with device manager and goto usb all the way down. Dont play with anything else there. Dlt usb thing from manages and refresh it later it will work i think then.

Thats all i think.

May be your IC is the problem press it little bit more harder first take it out and put it in back again. Maybe work

Maybe restart your system.

Hey try that with RS 232 Male and Female connector first to make sure weather u have problem with stamp or with RS 232 to USB.
I think ur system is old which windows u have u dont do update.
Sometimes updates are for good.
Try other system first.
I am just student. I might be wrong.

Post Edited (Sandhuamarinder) : 4/17/2010 6:53:08 AM GMT