PDA

View Full Version : Com Port problem Vista



Don J
04-13-2010, 11:07 AM
I am trying to communicate with a BS2 using Windows Vista and I keep getting stamp not found.
Anyone have any insight ?
I have a Dell Latitude with an actual serial port.
I've checked the baud rate etc..etc.. and still no luck.

Just got back into stamps and I used Windows XP prior to this without any problems.


Thanks Don J

erco
04-13-2010, 03:08 PM
1) Stamp known good? Plugged in properly to the board?
2) Does Vista support the serial port? You may need a virtual serial port; a USB-serial adapter. Try an XP computer w/serial port and make sure your cable works. Null modem cables don't. On some computers, you don't need a cable, you can plug the Stamp Carrier or BoE directly onto the computer's serial port. BTW, I'm using Vista with a USB serial adapter, no problems.
3) A low battery is often the culprit.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
"If you build it, they will come."

hippalator
04-13-2010, 07:44 PM
Just hooked up the serial BOE to my windows 7 and worked just fine.
I know window7 is not Vista but from the IT department here at work Windows 7 is Vista revamped.

Don J
04-13-2010, 10:04 PM
I'm going to try a known working computer running XP.
I use a USB to serial converter called an Edgeport.
This had worked well for me a couple years ago.
Also this is an OEM BS2 that I just put together.

Don J

Don J
04-13-2010, 10:30 PM
Ok, no luck using the Edgeport converter with a known working computer.
This was a known working configuration a few years ago.
When I do a control I the port status shows loopback = yes on the port that the stamp is connected to.
When I try to upload the program, I still get stamp not found.

My first thoughts are that the stamp was not put together properly, but I have soldered these
before without a problem and there just isn't a whole lot of rocket science to it.

Continuing testing...

Don J

Don J
04-13-2010, 10:55 PM
Ok, Progress !!!

I had a Rev A2 board laying around.
The A2 Compiler and Pic were damaged in an earlier incident.
Took the Pic and Compiler out of my new Rev B board and plugged it into my A2 board.

The BS2 is now working properly on my Vista machine.

So, now..trouble shoot the Rev B board and get that operational.

Don J