PDA

View Full Version : ERROR : No Basic Stamp found !!!!!



Tunisiano
02-23-2010, 04:51 PM
Hi,
I'm facing a new kind of problem here with Basic Stamp :
When I try to run a program the computer can not read the Basic Stamp anymore and an error message similar to the one that appears when the board of education is off shows up in my screen "No Basic Stamp found", sometimes I have to restart the whole system so that it can read the connection with the Basic Stamp again. Even though, sometimes the program can't execute the code and the Robot stays fixed, I tried it with my old classical codes that used to work properly and still have the same problem. This is driving me really crazy and I need to understand what's really going on here !!!

dandreae
02-23-2010, 11:02 PM
Do you have a voltmeter?· If so, measure:

Vin to Vss =
Vdd to vss =
Rst to Vss =

Vin should read the same as your power source.

Vdd should read 5 volts.

Rst should read 5 volts.

Dave

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Dave Andreae

Parallax Tech Support·

Tunisiano
02-25-2010, 04:48 PM
Vin to Vss : 4.44 V
Vdd to VSs : 4.4 V
I don't see what you mean by Rst.
I want to add that sometime the system can ensure the connection with BS2 but the robot doesn't want to move anymore, or it moves for a while then it stops ( I'm sure about the code, it used to work before).
Thanks for replying.

Mike Green
02-25-2010, 11:42 PM
There's something wrong with your power supply. Vdd (to Vss) must be 5V (4.5V to 5.5V or closer). For that to happen, Vin must be at least 6V (maybe 5.5V to around 9V). Try fresh batteries or an AC power supply that puts out 6V to 9V at up to 1A.

C-Bob
02-26-2010, 02:48 AM
Yes, one tips for all - please never use 9V zinc battery (alkaline is bit better and much expensive) - small capacity, bad voltage / current characteristic. Compatible connector on module is nice joke from Parallax (teachers dont laught). Soft power supply is responsible for many "random" malfunction and unwanted behavior.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
C-Bob

Every problem·have at least one·nice, simply and·wrong solution.

Tunisiano
02-28-2010, 07:31 PM
I tried it in another board of education and I got :
Vdd to Vss : 4V
Vin to Vss : 4 V
This is drinving me crazy, the hexcrawler does not move and I can't do any presentation anymore.

C-Bob
02-28-2010, 08:02 PM
Of course, every answers you need you find in Mike comment...
Change power supply.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
C-Bob

Every problem·have at least one·nice, simply and·wrong solution.

Tunisiano
02-28-2010, 08:08 PM
It's not connected to a power supply anymore, the sevo controller board (which was connected to a power supply) is now connected to four 1.5V batteries, and the board of education is connected to a 9V battery.

Loopy Byteloose
02-28-2010, 09:41 PM
Four 1.5V batteries equals 6.0volts. That may be below the voltage needed by the Basic Stamp's regulator. It needs closer to 7.0 volts to not brown out.

This is not a low dropout voltage regulator. I believe it is a standard 7805.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Ain't gadetry a wonderful thing?

aka G. Herzog [ 黃鶴 ] in Taiwan