PDA

View Full Version : ERROR... " Basic Stamp 2 Not Found "



tejapola
02-04-2010, 11:51 AM
Hi,
I've encountered an error while connecting my laptop to ARobot. After loading the object code and trying to run it, it gives an error #23 Basic stamp 2 not found.
Any help is appreciated.

Mike Green
02-04-2010, 12:24 PM
I know the forum search function is poor, but this is a very common question that's been answered many many times before. 90+% of the cases of this error are due to:
1) Lack of power for the Stamp. The Stamp's processor must be running for it to be seen by the Stamp Editor.

2) Faulty connection between the Stamp and the PC. Sometimes this has been a broken cable. If a USB connection, sometimes it's a broken USB cable or USB to serial adapter. Many USB to serial adapters won't work for programming a Stamp (or other microcontrollers). All of Parallax's microcontrollers require that DTR (Data Terminal Ready) be implemented properly. Most FTDI-based adapters work and Keyspan's High Speed Serial Adapter works. You do have to have the proper manufacturer's USB drivers installed. The default Windows driver will not work for downloading programs.

kf4ixm
02-04-2010, 12:30 PM
Maybe someone could make a 'sticky' at the top of the basic stamp forum that would outline the most common remedies for this... just a thought.

Mike Green
02-04-2010, 12:33 PM
@kf4ixm - It's already been done. There's a "sticky" thread called "Member Supported FAQ" that has this information in it. A lot of people just don't bother looking for the answer before they post a question.

kf4ixm
02-04-2010, 12:36 PM
ahhh, ok, i did not know that, guess i should have read that pesky ole' FAQ myself, lol.