PDA

View Full Version : Parallax Serial Terminal in Linux



tdeyle
12-19-2009, 12:36 AM
I am trying to run the PST Debugger under WINE on my Ubuntu 9.10 machine through the serial port.

I would like to know if anyone on the forums using Linux was able to use this program, and how did they do it?

I have combed the Wine-hq.org site trying to find an answer: I believed it has to do with how Wine configures the serial ports and how the programs interact with them. I configured the /dev/ttys0 as they stated here: www.winehq.org/docs/wineusr-guide/misc-things-to-configure (http://www.winehq.org/docs/wineusr-guide/misc-things-to-configure), but to avail.

I was just wondering if anyone has given this a shot and it came out working.

Post Edited (tdeyle) : 12/18/2009 4:42:20 PM GMT

David Carrier
12-19-2009, 01:43 AM
tdeyle,
The Propeller Tool, Propellent, and Parallax Serial Terminal all use the same API calls to use the com port. As far as I understand, WINE does not support some of these APIs. BradC was able to get the Propeller Tool working under WINE (http://forums.parallax.com/showthread.php?p=734252), but as of version 1.0.1, it does not look like his patches have been integrated.

-- David Carrier

AJM
12-19-2009, 03:12 AM
I was able to get everything working under linux (propeller tool, PST, etc) but the COM ports. I had tried several methods that supposedly worked to no avail.

Someone was kind enough to write a post with a link to their blog on how to successfully set up the serial ports.

This has worked for me. I would suggest giving it a try: Link (http://forums.parallax.com/showthread.php?p=847020)

I had the trial version of viewport running under linux, initially, without serial port recognition. Unfortunately, I was past the 30 day trial limit when wine was configured correctly and can't comment on its performance yet.

tdeyle
12-19-2009, 05:19 AM
Funny! I found that on the Wine forums! I am thinking that it might have to do with the updated Wine package that I have. I am going to try to install the one he is mentioning.

<EDIT>
I actually do have that version. But, I am using the serial port, not the USB. I think this is why it did not work. I saw in the BST threads that they are having trouble with Ubuntu 9.10 recognizing FTDI chips. I don't have one, I have a USB to Serial Converter with a Prolific chip. Supposedly, the drivers are included with the 2.6+ kernel. But... it still isn't working.

I even tried Sun's VirtualBox with an XP install: no dice. When there is a repeat loop in the SPIN program, the VB crashes.

I'll try reinstalling Wine and see if that cures it.

Looks like I won't get any sleep tonight!

Post Edited (tdeyle) : 12/18/2009 9:31:53 PM GMT

Ale
12-19-2009, 05:49 AM
No need for tricks, use BST:

propeller.wikispaces.com/Mac+and+Linux+native+development (http://propeller.wikispaces.com/Mac+and+Linux+native+development)

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Visit some of my articles at Propeller Wiki:
MATH on the propeller propeller.wikispaces.com/MATH (http://propeller.wikispaces.com/MATH)
pPropQL: propeller.wikispaces.com/pPropQL (http://propeller.wikispaces.com/pPropQL)
pPropQL020: propeller.wikispaces.com/pPropQL020 (http://propeller.wikispaces.com/pPropQL020)
OMU for the pPropQL/020 propeller.wikispaces.com/OMU (http://propeller.wikispaces.com/OMU)

tdeyle
12-19-2009, 08:02 AM
I do use BST, but I wanted the Parallax Serial Terminal because I like to use the Spin Debugger that Parallax released. I already tried the terminal that is built-in BST, but, it doesn't have the same formatting as the Parallax.

And.. it looks like I will be getting some sleep after all! It turns out that the Wine version that the Ubuntu repository has is 1.1.34. I was removed it, then installed it again, this time forcing that revision 1.0.1.

I relaunched the Parallax Serial Terminal, reloaded the Propeller with the PST Debugger Demo in BST and bam! It worked!

Thanks AJM, for mentioning that link again!

AJM
12-19-2009, 09:27 AM
I'm glad that it worked for you too. All credit goes to the original poster

I also use BST pretty much exclusively. In this case I feel the effort is worth it, especially if the propscope works under linux. I can't see why it wouldn't. Some day I will have to order one.