PDA

View Full Version : Propeller Tool issue



Untel
12-15-2009, 11:57 PM
This topic was sent last week and it is no longer present on the forum ???

Closing Propeller Tool using the [X] windows button does close the Propeller tool but does not terminate the application.
Using the Windows Task mamager shows that it is still running and slow down the process.

I got one answer from a member telling me that this is not the only issue with Propeller Tool.
Just wonder if any one at Parallax will care enough to giving me any kind of answer on this.
Regards

Rayman
12-16-2009, 12:37 AM
I just tried at and don't see it in Task Manager...

Does it happen every time for you?
What version of PropTool ?
Which Windows?

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
My Prop Info&Apps: ·http://www.rayslogic.com/propeller/propeller.htm

Untel
12-16-2009, 12:47 AM
Version 1.2.7 and precedent version of the tool will give this issue on every closure using the [X] button
I ham running Propeller tool on Vista Pro.
Tanks helping!

Bob Lawrence (VE1RLL)
12-16-2009, 12:59 AM
Untel said...
This topic was sent last week and it is no longer present on the forum ???




Try This:
http://forums.parallax.com/showthread.php?p=863027

tdlivings
12-16-2009, 01:18 AM
Windows 7, Propeller Tool 1.27 closes·using the x fine.
Parallax Serial Terminal also closes using the x fine
No trace in Task Manager.

I tried running multiple copies of Propeller Tool and did not
see more than one in Task Manager but did get an access
violation dialog pop up while looking at Task Manager. Upon
closing Task Manager and then using the x to close Propeller
Tool I see no sign of Propeller Tool in Task Manager.

Tom
·

Leon
12-16-2009, 01:26 AM
It sort of crashes every time I close it. I didn't know there was a version 1.2.7, I'll try that.

1.2.7 seems to have fixed the problem.

Leon

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Amateur radio callsign: G1HSM

Post Edited (Leon) : 12/15/2009 5:45:09 PM GMT

Untel
12-16-2009, 03:07 AM
There is no problem if you close Propeller Tool just after openinig it. I got this issue after using it for a while.
Thanks

Jeff Martin
12-16-2009, 06:40 AM
Hi,

We are aware of this problem and trying to solve it. It seems to happen a lot on some systems and not at all on others. We've been collecting bug reports from this for quite a while to narrow it down as it seems to be related to an invalid pointer created by processing Windows messages in a different order than intended. We are working on this and many other fixes and enhancements and will release as soon as possible. The readme notes will mention the correction of this bug with words like "fixed exception error that can occur upon closing..."

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
--Jeff Martin

· Sr. Software Engineer
· Parallax, Inc.

Roy Eltham
12-16-2009, 07:06 AM
I occasionally will get an exception error on exit from the PropTool. I'm using Vista Ultimate 64 on one machine and Windows 7 Pro 64 on the other machine. It definately seems to be related to how long I've had the tool open and how much I have done in the tool. It never happens if I have a short session.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Check out the Propeller Wiki (http://propeller.wikispaces.com/)·and contribute if you can.

Kye
12-16-2009, 07:11 AM
I get this error too alot. It seems harmless but is rather annoying.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Nyamekye,