PDA

View Full Version : RFID Reader questions



ncooper
10-21-2009, 12:19 AM
I just purchased the RFID Card Reader (Serial, #28140) and a handful of Rectangular RFID tags (28141), 50mm round tags (28142) and 25mm Round tags (32397). I have the Reader wired into a Parallax BOE board with a BS2 cpu, running off a wall wart, not a battery. After messing around with the hardware and software I finally got things working, but not to my expectations. First, the reading distance is not 4 inches, more like 4mm. Yep, that just a bit over 1/8 inch. And, only the large rectangular card and the 50mm tag can be read. The reader will not read the 25 mm tags, ever.
But, before I discovered the limited reading distance, I first had to get the software working. I downloaded the available software (RFID_basic.bs2) and tried to run it. It didn't work. After some debugging, I determined that the program was hanging up at the SERIN statement. The first thing the program looks for from the RFID tag is the Start Byte (the number zero). Unfortunately, the supplied tags apparently do not have a 12 digit ASCII ID (per the data sheet) and the Start Byte is not 0. So, the Reader will sit there all day waiting for a Start Byte that does not exist. If you remove the "[WAIT ($0A]" statement from the SERIN command line, the READER finally works and reads the tags unique ID. But, it's only 9 digits, not 10. OK for my application, but again, not what I expected.
So, the questions are...did your tag vendor change specs? Is there Start Byte? What is it? Does the Parallax BOE not provide enough juice to the Reader to obtain the maximum reading distance? How do I obtain the 4" reading distance as advertised? Is what I'm seeing typical or am I just doing something wrong?
Comments cheerfully accepted.http://forums.parallax.com/forums/emoticons/smile.gif

Mike Green
10-21-2009, 02:28 AM
1) The $0A (and the terminating $0D) is supplied by the RFID Reader, not the tags. The RFID reader should be supplying it. The tags I've bought have had a $00 as the first byte of the ID code.

2) The two RFID readers I've used both had ranges on the order of 4" as specified.

3) There's clearly something wrong with your setup or your RFID Reader. A drawing of your connections and a listing of your program would help a lot. I've used the RFID readers with several different Stamps on a BOE and they worked just fine with both Parallax's tags and some little capsule-like ones. Make sure you don't have some kind of sheet or large piece of metal close to the RFID Reader like a metal benchtop or something like that.

4) You could always try calling Parallax's tech support people. It's odd that the Reader and tags are not working for you. The setup you're using (a BOE with a BS2) is pretty standard and the documented sample programs should just work according to spec.

ncooper
10-21-2009, 03:59 AM
Thanks Mike,

Referring to your Item 1, I obviously misunderstood the code. I stuck the code fragment "[WAIT ($0A)..." back in and it works fine. Also, returns 10 digits for the tag ID like it should. I think I had done some code hacking prior to removing hte "WAIT" statement, so I just screwed myself up.

In regards to the reading distance, the Reader is sitting on an all wood bench top. I went ahead and moved ALL metal away at least 2 feet. Still only reads tags within 1/4 inch. And won't read the 25mm tag at all.

I have to suspect there's something wrong with the reader. Setup/wiring couldn't be simpler...Vcc to Vdd on BOE, GND to Vss, ENABLE to Pin 0, SOUT to Pin 1. Double checked my voltage to Reader and it's 4.9 volts.

I just went back and un-zipped a virgin copy of RFID_basic.bs2 and ran it. It works fine, with no modifications. I guess I didn't think the software was working because originally I was holding the tags about 1-2" from the reader.
So, it looks like I'm down to only 1 problem...measuring range. That has to be a defect in the Reader.

Mike Green
10-21-2009, 04:17 AM
I think there was someone else with a similar problem shortly after the RFID Reader came out. It turns out they had a short (solder bridge) on the board. Call tech support.

ncooper
10-21-2009, 05:39 AM
Good memory. I found a solder bridge between 2 legs of the PIC chip. I'll contact Tech Support to exchange it for a new one. Thanks for your help.
Neal Cooper