PDA

View Full Version : I am having a really bad problem with the propeller tool



pilot00
01-26-2009, 05:53 AM
I have submitted this problem before but I cannot get things working again.
I can only get programs to load intermittently. I have deleted everything.
Re downloaded new software, checked drivers, deleted everything and reinstalled
everything. Still the same problem. Even added xp service pack three and no changes.
HELP!!!

SRLM
01-26-2009, 06:46 AM
Is your propeller reliably powered?
Do you have a com port open when you attempt to download? For example, the serial terminal when enabled blocks the com port.

pilot00
01-26-2009, 06:55 AM
I finally figured it out. Josh at techsupport told me of a problem with
con
_clkmode = xtal1 + pll16x
_clkfreq = 5_000_000

I suddenly remembered this and experimented. Nothing works at pll16x only pll8x and below.
Apps that do not use this con block work. When added they stop working at 16x but work at
lower speeds.

I have just spent an hour experimenting with adding and deleting the con block to apps and changing
the speeds and this appears to be the culprit.

Thanks for your help.

Martin

Phil Pilgrim (PhiPi)
01-26-2009, 07:26 AM
Martin,

Are you using the Spin Stamp? That module has a 10MHz crystal, and you should specify it thus:




con

_clkmode = xtal1 + pll8x
_clkfreq = 10_000_000




pll16x will not work because that results in a clock frequency of 160MHz, which is beyond the Propeller's specs.

-Phil

Cluso99
01-26-2009, 07:32 AM
This doesn't make sense to me as I use this all the time. Is your crystal 5.00MHz? Maybe the PLL is not working (chip failure)?

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Links to other interesting threads:

· Prop Tools under Development or Completed (Index) (http://forums.parallax.com/showthread.php?p=753439)
· Emulators (Micros eg Altair, and Terminals eg VT100) - index (http://forums.parallax.com/showthread.php?p=778427)
· Search the Propeller forums (via Google) (http://search.parallax.com/search?site=parallax&client=parallax&output=xml_no_dtd&proxystylesheet=parallax&proxycustom=<HOME/>&ie=&oe=&lr=)

My cruising website is: ·www.bluemagic.biz (http://www.bluemagic.biz)

Phil Pilgrim (PhiPi)
01-26-2009, 01:44 PM
If the PLL wasn't working, _pll8x would not work either, since it's divided from the 16x clock. I suspect he's using a 10MHz crystal. I make that mistake all the time, since I'm working with both crystal frequencies on different boards. I'm almost embarassed to say how much time it costs me every time I do it!

-Phil

pilot00
03-08-2009, 12:25 AM
Problem was solved due to a malfunction on the propeller chip. Parallax replaced the chip. thanks for the support.
Martin