PDA

View Full Version : Help with FTDI and Propeller



tazdar
01-08-2009, 05:39 AM
OK, Ive spent the past 2 weeks trying to get this to work. I ordered a Propeller chip from Digikey about two weeks ago. Originally my plan was to build to serial programmer circuit included in the data sheet. When that didn't work I orderd one of these, (http://search.digikey.com/scripts/DkSearch/dksus.dll?Detail&name=768-1018-ND) a USB to Serial 3.3V TTL Adapter. I cant get it to work either. No matter what I do the Propeller Tool says no propeller chip found. When I ground the RESn pin temporally, I can see no evidence of a reset (although I don't have a scope). But if I pull the power out of it and plug it back in I get "00" over the serial port.

Here's (http://tinypic.com/view.php?pic=r85g8n&s=5) a pic of my layout.

Also, before I made the power supply, I was powering the chip with an arduino's 3.3V output.

Any help would be greatly appreciated.

grasshopper
01-08-2009, 05:52 AM
I would think that in order to get it to work correctly you would need to place a transistor that could be used by the USB chip (using the DTR) to toggle the reset pin on the propeller. Otherwise I imagine that it would work, but I have not seen the USB data sheet.

You could also order a Prop plug.

tazdar
01-08-2009, 06:07 AM
Thanks for the quick response, here's (http://www.ftdichip.com/Documents/DataSheets/Modules/TTL232PCB_PADS.jpg) the pin out for the usb to serial. I'm not sure on the details of RTS/CTS or DTR but I have the RTS pin on the usb running to the RESn pin directly on the propeller. I set the reset signal to RTS in the prop tool as well. Lastly, is there any way I can tell if the chip is working without the serial working?

Thanks for the help.

StefanL38
01-08-2009, 06:19 AM
Hello tazdar,

I took a look into the datasheet (http://www.ftdichip.com/Documents/DataSheets/Modules/DS_TTL232R.pdf) of the
TTL-232R USB to TTL Serial Converter Cable

on page 5 is a table describing
The RS232-pins that are connected to the TTL-side are

1 GND GND Black Device groud supply pin.
2 CTS# Input Brown Clear to Send Control input / Handshake signal.
3 VCC Output Red +5V Output
4 TXD Output Orange Transmit Asynchronous Data output.
5 RXD Input Yellow Receive Asynchronous Data input.
6 RTS# Output Green Request To Send Control Output / Handshake signal.

So as you mentioned you have to setup the proptool to send the reset signal on RTS
and if you take a close look into the circuit of the propeller-datasheet page 5 2.3.2. Alternative Serial Port Connection
there is a capacitor of 0.1 F between serial-plug and resetpin of the propeller

one thing
you could test if there starts some bitbanging on IO-Pins 28,29 right after powerup (propeller trys to communicate with the EEPROM connected to pins 28,29)

second thing write a small testprogram save the binaryfile of it
load binaryfile into an 32kB EEPROM using any kind of programmer and connect it to the propeller

best regards

Stefan

Post Edited (StefanL38) : 1/7/2009 10:37:07 PM GMT

tazdar
01-08-2009, 07:06 AM
Tried the capacitor, no joy :( Thoughts?:)

Thanks!

Ariba
01-08-2009, 07:38 AM
Try to invert the RTS signal with MPROG (an FT232 configuration program from FTDI), and add a 10..100nF C between the RTS and Reset input. Or use the transistor circuit here:
http://forums.parallax.com/showthread.php?p=774630

> "Lastly, is there any way I can tell if the chip is working without the serial working?"

If you have a o'scope you can look at the PA28, PA29 to see if the Propeller tries to access the EEPROM. Evt. you need a Pullup on Pin PA29 for that (2..10k).
If you have no Scope, perhaps a LED flashes briefly when attached at PIN PA29 to +3.3V over a ~200 Ohm resistor. But the pulse may bee to short to see.

Andy

tazdar
01-10-2009, 01:21 PM
Hey thanks for the responses guy's, inverting the RTS signal with MPROG worked great.

Thanks