PDA

View Full Version : Odd reset with USB Proto board, Help please.



TJHJ
01-08-2009, 01:48 AM
So this is from a client who I am doing some design work for, Right now I am unable to see the project but I cant reproduce these conditions when I do have it, so any ideas.

Ok the project is a set of solar panel tracking software. It is a two motor system driven by 2 H55B parallax H-bridges.

Currently It is a hand built prototype based off a USB Proto board. So non production level.

The tracking side is all fine ect. I have a terminal based debug system that just feeds sensor/ position information to the terminal to help in debugging/ tuning.

The motor drivers are turned on by a hard 12v automotive relay, that is switched using a NPN driven by the prop.

My 1st suspect was that the battery he was using was low, and when the system would try and move to fast it would drop the voltage to much and cause a reset. So he moved to a running truck battery to no change.


Customer said...


What I have figured out is that if my laptop is plugged into the machine, it will never have a problem. Not very long after I unplug either end of the USB cable, the drivers will start turning on and off. ( I asked him to power the board up with the usb completely removed from it, and He reports no change. The driver on/off is a result of the propeller board restarting. ) The machine keeps operating fine with the laptop plugged in, even in I am not using the Propeller Tool or the PST. I tried running the machine off my truck batteries with the engine running, and it did not help. The only thing that made a difference was just plugging in my laptop and it was fixed instantly with out me doing anything else. I don't know what the solution is, but that is what the problem is.





So Any ideas here? Is it picking up some weird noise that is making the FTDI chip reset and reset the prop system? Anyone experienced a similar problem? Any ideas on how to fix this?

Before I gave the machine back to him, I ran it without any usb connection just fine, for a very long time 8 hours plus and never once did I see these same conditions. I am totally stumped here. So please help me, and thank you for the time as always.

Thanks as always,
TJ

Phil Pilgrim (PhiPi)
01-08-2009, 02:14 AM
This is a known issue with Parallax's USB interface design. (Note to Parallax: Come on guys. As I've mentioned before, this is easy to remedy with a 15-cent buffer.) A workaround is to put a 1K pullup from A30 (a.k.a. P30) to Vdd. Here (http://forums.parallax.com/showthread.php?p=651731) is a thread that explains everything.

-Phil

TJHJ
01-08-2009, 02:27 AM
Any chance you could elaborate on this 15c buffer so If I do a board design I dont have the same problem?

Edit, the last post in the linked thread talks about some issues relating to resistor size and pulling to Vdd. Should it be to Vdd or to 5v?

Thank you.

TJ

Post Edited (TJHJ) : 1/7/2009 7:35:12 PM GMT

Phil Pilgrim (PhiPi)
01-08-2009, 03:19 AM
TJ,

Here's a schematic:

http://forums.parallax.com/attachment.php?attachmentid=57861

The buffer is an LVC-type and open drain. Both these combined mean that:

1. input signals cannot power an unpowered chip or make it to the other side, and

2. the pullups will not power the chip either.

In the meantime, to answer your second question: Vdd not +5V. Also, as part of the workaround, make sure your program does not toggle A30.

-Phil

Post Edited (Phil Pilgrim (PhiPi)) : 1/7/2009 8:27:27 PM GMT

grasshopper
01-08-2009, 04:07 AM
Well I have went around this problem by inserting a jumper to open/close the reset line going to the propeller. Like the ones used on hard drives. Of course when I need to re-program the propeller I have to reinsert the jumper. Next board revision ill put in a micro dip switch like seen on computer motherboards.