PDA

View Full Version : BOE: Basic Stamp Not Found



mac3a
09-19-2008, 08:03 AM
Hi there,

I have a board of education with basic stamp 2, and after installing the windows editor and USB drivers my computer won't detect the basic stamp. I've tried in two different computers and none of them work. I've also tried two different BS2 microcontrollers and nothing.

I'm using the wall mount power supply, so no battery problems either.

Any help would be greatly appreciated.


Miguel

Franklin
09-19-2008, 08:35 AM
What does it detect and what messages are you getting? The more info you give us the more likely we can give you an answer.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
- Stephen

mac3a
09-19-2008, 08:55 AM
Hey Stephen,

When I go to Run > Identify... it should detect the basic stamp in the COM3 port, but it doesn't show anything.

If I try to run my code, since it doesn't detect the microcontroller, I get a No Basic Stamp Found error.

Mike Green
09-19-2008, 11:10 AM
What kind of USB adapter are you using? Not all of them can be used for programming a Stamp.

As you may have noticed from other peoples' messages on this subject, most problems of this sort are
due to lack of power for the Stamp or some problem with the serial connection with the Stamp, usually
the wrong USB driver (for USB) or a bad cable. Occasionally a Stamp is inserted improperly into its socket.

mac3a
09-19-2008, 08:02 PM
I'm using the USB cable that came with the kit. I have other USB cables that I know supply more power, but I'm afraid if I use one of those it can damage the microcontroller

allanlane5
09-19-2008, 08:07 PM
Did you install the FTDI USB drivers? The USB drivers MUST match the USB device you're trying to use.

And yes, the symptom you describe is typically when the board (and USB) are properly connected, but the BS2 is not properly powered. An unpowered, but properly connected BS2 will pass Echo and Loopback, but will then not complete the rest of the reset sequence.

And what do you mean "other USB cables that supply more power"? USB cables are all alike, no?

Also -- have you installed any wires on the prototyping area? Inadvertently shorting Vdd to Vss can cause this too.

mac3a
09-19-2008, 08:34 PM
Guys,

I just tried again and this time the BASIC Stamp was successfully identified. I wish I could tell you how the problem was fixed for future reference, but I have no idea; I haven't done anything differently.

Thanks for your time and help!

allanlane5
09-19-2008, 08:39 PM
Then it might be an intermittent USB connection (unlikely) or an intermittent power connection, or even the module needed a little re-seating in the socket. You can check these things if it happens again. Otherwise, happy computing!

Tala
11-01-2008, 08:08 PM
Hi
I just bought a BOE-BOT kit and have some issue with the identification: When I turn OFF the board: the Loopback and the Echo are Yes, but if I turn it on - the echo becomes No...
I use the 4 AA batteries and the USB cable what the package contained to this BOE USB. I also installed the newest Parallax USB driver...
Looks like all the pins are in their place and I have no clue what would be the reason. I've tried to change the COM port setting, even different USB ports, but the same happens...And I could move the stamp until I got the Loopback and Echo on Yes - when it was turned on but anyway not really helped...
Then I moved the chip, pushed deep down because I was like: "maybe I am too gentle and need some more push" - but nothing happened...and then when I pulled out - unfortunately two pin fell from the stamp - so I soldered it back gently and looks like okay, so I reinserted and the exact same result I got...
I have ordered a Javelin kit as well, but the shipping takes time to here(Central Europe), so the basic idea was to learn it in basic(I work as a java programmer anyway) and then do the fun with the javelin, but the situation came into this:)

If you have any suggestion - pls share, it would assist...
thanks
tala

mac3a
11-01-2008, 09:15 PM
Hey Tala,

Did you check to see if you inserted the Basic Stamp correctly? Check if it is inserted in the right direction.

Also, disconnect any components you have connected, such as the QTIs, motors, etc. and see if your computer can detect the basic stamp correctly. Sometimes what happens is that if you have a component connected incorrectly the computer will not detect the basic stamp. If this works, then make sure you double check your connections when you put everything back.

Good luck!

$WMc%
11-02-2008, 01:11 AM
Tala

I have noticed that USB printers and "Roxio easy CD creator 5" can tie up the USB ports... Take a look in the DEVICE MANAGER under com ports/USB...Also the TASK MANAGER....... Its just A tought and A possiable solution........I had to uninstall "Roxio" to get My Propeller Pro.Dev.Board to work.


_____________$WMc%____________________________out_ _________________

Tala
11-07-2008, 02:21 AM
Hey mac3a & WMc

Thanks for answering - I will recheck during the weekend, but yes I've put it as the book mentioned, and I have only connnected the batteries to the board and the chip and the USB cable - and for a moment it blinked up in the 'Indentifier prg' and I was like YES - but it was just a glimpse and did not repeated - and then I moved and caused the break..hmm
What I noticed that there is 2 tiny leds are blinking up a red and a blue when I connect to the USB...
And I will reinstall the windows and will try again, maybe a driver can cause it...

so again: thanks so much..
tala