PDA

View Full Version : bs2sx programming



thegoat001
09-16-2008, 08:28 AM
So I got my bs2sx in the mail yesterday and rushed to the school lab to program it. I used a serial to serial cable from a computer operating with windows XP. For some reason a bs2e is recognized in the programmer but not the sx. When I run the identify command the loop and echo both say yes, but an error message saying, "no basic stamp found" pops up. Any thoughts on why the software would see the e but not the sx? I can't tell you the model number of the programmer being used, but I'll put it up once at school tomm. I ordered my own programmer so that I can try it on my home computer. The one thing I did not try was checking FIFO for the com port because I did not have admin privileges on the school comp. If the e works I'm not sure if this is a possible problem?

Mike Green
09-16-2008, 08:35 AM
There were some very old versions of the Stamp Editor that could program some models, but not others. Make sure you have a reasonably recent version. It's always best to check your Stamp Editor version against the current version on Parallax's website.

Good thinking about checking the FIFO, but it's usually a problem with USB to serial adapters, not so much serial com ports.

Make sure there was power available to the BS2sx. The two most common, most frequent causes of failure to program (by far) are: 1) lack of a good serial connection including the handshaking lines; 2) lack of power to the Stamp. #1 you've tested by being able to identify a BS2e. #2 might have changed between testing with a BS2e and your BS2sx.

thegoat001
09-16-2008, 08:47 AM
I tried a new battery, forgot to mention that. I'll check the version of the stamp editor program tomorrow and get back to you. However, BS2sx does appear as a possible selection in the program menu. Thanks for you help.