PDA

View Full Version : Newb question - servos wont spin



Newb Fiddler
09-05-2008, 04:53 PM
Hello, I'm working through the Boe-Bot kit tutorial and am stuck at Ch2 Activity 6 testing the continuous rotation servos. I'm using Board of Education Rev C

The servos have never moved andĚnever made a sound. So I don't know if the units are broken or if I'm configured incorrectly. I think I've exhausted the high level configuration permutations. I think power is not getting to the servos or they're broken.

Any help or tips appreciated. Here's what I've tried so far:

Simplified my circuit to contain only the LED and 470 ohm resistor between theĚP13 io pin and Vss on the breadboard and connected the servo to the BOE inĚsocket 13.

Verified that my code properly signals on that pin, lighting the LED.

' {$STAMP BS2}
' {$PBASIC 2.5}
DO
PULSOUT 13, 650
PAUSE 20
LOOP
END

I've varied the pulsout duration from 650 to 850
I've varied the io pin choice and recoded, breadboarded for pin 12
I've tried both servos in each configuration
I've varied the power source jumper, but left it back at Vin (battery pack)
I've varied the power source from AA pack to 9V battery
I've reversed the servo plug into the BOE and back
I've adjusted the potentiometer on the servo while the program was running.

I'm stumped!!

Bruce Bates
09-05-2008, 05:14 PM
The manual for the continuous rotation servos can be found here:
http://www.parallax.com/Store/Accessories/MotorServos/tabid/163/CategoryID/57/List/0/Level/a/ProductID/102/Default.aspx?SortField=ProductName%2cProductName

If you have further questions after reading that documentation, just ask.

Regards,

Bruce Bates

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Involvement and committment can be best understood by looking at a plate of ham and eggs. The chicken was involved, but the pig was committed. ANON

allanlane5
09-05-2008, 08:50 PM
You can't drive BOTH an LED and a servo off the same pin at the same time. You CAN put the LED on to verify your program, then take the LED off and put the servo ON.

You might try "PULSOUT 13, 500" to get 'full speed' out of the servo.

Chris Savage
09-05-2008, 10:39 PM
Have you moved the power switch into position 2? In position 1 the BASIC Stamp gets power, but not the servos. In Position 0 everything is off. Try sliding the switch all the way to the right.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Chris Savage
Parallax Engineering

Newb Fiddler
09-06-2008, 01:45 PM
That was it! Moving the switch to position #2 powered up the servo. I loked back through the instructins and saw the nte about witch positin there. Dn't know how I missed it.

To the earlier post, the LED works fine along with the servo on my board.

Thanks for the help!