PDA

View Full Version : FTDI problem



Adriano72
04-30-2008, 08:08 AM
Hi all, just got my hydra, parallaxdroids works, breakouts works

Plugged usb to pc and it (XP) recognized correctly FTDI, "the new hardware is ready to use etc..." (didn't asked me to search for drivers as written on the book. It simply recognized it.)

Then, besides the Propeller tools doesn't find it, the pc gives "USB Device not recognized" (translated from italian...). And gives this message periodically while the tx/rx leds flashes...

This was tried on two different pc. The XTAL and the Propeller are well pressed, the mouse is not plugged.

One time I got it seeming to work, under devices on control panel I read "serial emulator" (or something similar). But the propeller tool doesn't find it. Then the pc gave again "Unknown USB device"...

I'm FRUSTRATED!!! It's 3 am and I cant connect the hydra with the PC...

I'm triyng to uninstall the drivers with the tools from the FTDI site and then reinstall it all... meanwhile anybody have some idea???

Thanks!!

Adriano http://forums.parallax.com/images/smilies/smhair.gif http://forums.parallax.com/images/smilies/smhair.gif http://forums.parallax.com/images/smilies/smhair.gif

allanlane5
04-30-2008, 09:22 AM
Key question: Did you install the FTDI drivers BEFORE you ever plugged in the USB device?

Because the default Windows driver WILL load for the FTDI USB to Serial adapter, but it is the WRONG driver. I think the book is wrong on this one -- you DO have to install the FTDI drivers before plugging in the USB cable.

Solution:· Unplug the USB cable.· Re-install (or install for the first time) the FTDI drivers.· Then plug in the USB cable.

Adriano72
04-30-2008, 02:54 PM
Thanks Allan, I tried, no way... http://forums.parallax.com/images/smilies/confused.gif

I uninstalled the bluetooth stack and the Blackberry desktop manager that created a lot of virtual COM ports.

Now I have no COM ports in the listing on the control panel.

Though when I clean up all using the tool from the FTDI site and reboot I follow Andre's procedure and at first the pc finds the new FTDI device. Then if I use the newset drivers it gives me the error 10 (con't initialize the hardware), and if I use the CD drivers it simply doesn't work.

Both the propeller tools supplied in the cd don't find any COM port and after a few tries the PC gives me the message "Unknown USB peripheral"...

My God, once at the gates of heaven I find out my key doesn't work...

AndreL
05-01-2008, 09:36 AM
Adriano,

Let's take some of the issues out of the problem. First, try this on another computer. A nice XP system that isn't hanging on by a thread. See if that works. Also, try another USB cable for kicks. Let's just make sure its not something stupid. Then if it works on your other computer, then we know the FTDI chip, usb cable, and everything is good, so then we can focus on why is your computer being so problematic.

Andre'

Adriano72
05-04-2008, 07:37 AM
Thanks Andrč and all,

after the night spent trying to make it work I left for a small vacation... now I'M back and I tried installing the driver from Parallax site... it works !!!!!!

now the problem is that I have two PAL tv. The biggest one works, but the more confortable to use to learn hydra programming display in black and white...
But at least now I can go forward...

Thanks!!

Adriano